Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After using MacBook for two years, I bought 17'' MacBook Pro.
I'm pretty happy with it, performance and all, but I also was going to record some music videos for YouTube. I play guitar and sing.

However I was extremely disappointed with the sound quality that comes by default. I'm 100% sure my 13'' MacBook mic was much better at recording music and singing.

Currently mic can't event handle acoustic guitar, outputting sound you'd think was recorded 5 years ago in ARM format on a Nokia phone on a loud concert. It totally feels like some lame filter is cutting low and high frequencies.

I want to know what settings (visible or hidden) in iMovie or Mac OS itself I might want to tweak in order to get my MBP mic record clean sound.

share|improve this question
I can't say I'm surprised given the constraints on both mic and speakers and the environment they run in. If you're committed to using (some of) the built-ins, have you tried built-in mic / external speakers, and a known good recording with the built-in speakers, to isolate the degradations due to each? – JRobert Mar 15 '11 at 12:44
up vote 6 down vote accepted

Okay, so eventually I did figure out what was wrong.

Of course, I'm not saying what I got is as good as a decent mic, however I find it much better now, even suitable.

What you'll want to do is go to System Preferences, choose Sound, select Input tab and ensure ambient noise reduction is unchecked for the internal microphone:

System Preferences - Sound - Input - Use ambient noise reduction is unchecked

Apparently, this option is enabled by default and controls a filter that distorts the sound that goes in through the mic. It may be good for noise reduction but in my experience recording is so much better with it turned off.

After you've killed the main culprit, go to iMovie, click button with a mic on it, and turn off Voice Enhancement:

iMovie - Voiceover - Voice Enhancement turned off

This may not have as dramatic effect but still I prefer the sound as raw as possible because Macbook's default processing somewhat disappointed me.

Also you should make sure that the sound level is not off-scale when you're recording. Note that iMovie input level setting is bound to System Preferences, i.e. when you change on of them, the other changes as well.

That's all I found so far to make Macbook Pro internal mic sound better.

share|improve this answer

My advice is to buy a real mic, however there are few settings, you could tweak.

They are located in the Audio MIDI Setup application (nothing to do with MIDI) - format (8kHz-92kHz, 16-32bit) and loudness.

The mic itself is located under the left speaker grille, you could try different recording distances, or disabling sound output from the speakers while recording. Closing or opening display a little could serve as sound reflector.

I don't think this could fix a crappy mic, but it's worth a try.

share|improve this answer
Didn't know about the Audio MIDI thing, thanks. – Dan Mar 15 '11 at 15:54

Of course the Pro isn't going to be much better. Dollars to Donuts says the Mic in it has the same part number on it as the one your old Macbook had. The "Pro" doesn't refer to its audio recording abilities.

My brother-in-law does the same thing with his Macbook. We ended up buying him an Audio Technica USB Condenser Mic. Works like a charm and the audio is head and shoulders above what the internal mic is capable of. If you're serious about recording, $100 is a pittance of an investment, especially when you just spent $3k on a 17" Macbook Pro.

share|improve this answer

I notice that when my volume input level is at more than 25%, my instrument gets distorted and blares. maybe try turning your input volume on your mac way down, then play and sing and watch the volume meter to make sure it's bouncing and not just full all the time.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .