Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I often am forced to view long PDF documents either in browser or out of browser. When I'm forced to use such documents, it's always frustrating, because whenever I scroll the document, the viewer "stutters" -- and it's at least some 30 seconds later before Acrobat relinquishes control of my mouse pointer. (I've found that if I Alt-Tab out of Acrobat, everything finishes scrolling instantly, and I get my pointer back)

I suspect that the issue lies in not having the world's greatest graphics card in this laptop (an NVIDIA Quadro NVS 160), but it scrolls so slowly that I don't think this is just a hardware problem.

Has anybody had this problem before? What does one do about it?

EDIT:

Interestingly, this only seems to occur if I use the "middle button scroll" on the laptop keyboard; if I plug in an external USB mouse and scroll that way the problem seems to go away.

EDIT2:

Replacing Adobe Reader with something else is not an option. Using alternative readers has bit me in the a** enough times that I don't want to deal with it. Unless it supports reading anything in a PDF that Reader X does, I'm not interested (and no third party reader does so).

More to the point, this occurs in other applications on this machine than Adobe Reader -- it's just that in Reader this problem is most noticeable. Using Foxit Reader, for instance, does not change the problem; it's still just as poor there as it is in the first party tool.

share|improve this question
    
For people who are having difficulty with Adobe Acrobat's scrolling speed and it doesn't appear to be graphics related, see: superuser.com/questions/570869/… –  Jonathan Jul 26 '13 at 22:35
    
Dont waste time working with it ... Install the free version of "PDF Exchnage Viewer" or better "Sumatra PDF". The Second I think is the best .... –  UltraDEVV Sep 23 at 6:06

15 Answers 15

@Jeff also suggested to update your drivers, it might help a bit if they were very outdated.

@Mehrdad's suggestion is just wrong, power-save is unlikely as external USB mouse goes just fine.

And this is what the documentation says:

Check 2D Graphics Accelerator (Windows only)

(Appears only if your computer hardware supports 2D graphics acceleration.) When selected, allows hardware acceleration usage when the first document is opened. When deselected, hardware acceleration usage starts after the first document is opened. This option can slow startup time, so it is unselected by default.

So, in short, it just starts the hardware acceleration earlier which does not have any effect on your scrolling.

Also, you don't want to enable smooth scrolling, as this results in more frames and thus worse performance.


So, here are my suggestions which can improve performance assuming the latest version Adobe Reader X:

Under Edit > Preferences:

  1. Page Display > Smooth Text > None

    Making your text more beautiful takes time, it might have an impact on your performance.

  2. Page Display > Enhance thin lines > Unchecked

    Similar to text, this might have an impact too.

  3. Page Display > Use 2D graphics acceleration > (Un)checked

    It's essential to try both states here, who knows your CPU is faster and thus software-based is faster.

    If you uncheck this, you might want to uncheck Smooth line art and Smooth images too.

You might want to learn to use your reader different, for example, run it in full screen mode like this:

  1. Go to View > Full Screen Mode or press Control + L.

  2. The default is to show the full page, other views can be accessed by Control + 0 - 5.

  3. Use PgUp and PgDown (or Space) to jump instead of scroll.

Another bunch of specific solutions are listed in this thread, but I doubt if they can help you...

If your problem in Adobe Reader isn't resolved, you could try an alternative reader like Foxit.

EDIT: Interestingly, this only seems to occur if I use the "middle button scroll" on the laptop keyboard; if I plug in an external USB mouse and scroll that way the problem seems to go away.

Interesting, try to see if you can update the drivers for your touchpad. Also check for any odd settings for it.

It is a branded touch-pad (check under Device Manager) can you mention to us which one?

share|improve this answer
    
@Tom: My suggestion is just wrong? It's happened to myself because of PowerMizer! I'm not sure if you have any idea what PowerMizer is, but it has nothing to do with USB mice... –  Mehrdad Mar 31 '11 at 3:52
    
@Mehrdad: I think you need to read the end of the question again. Your case is different... –  Tom Wijsman Mar 31 '11 at 13:52
    
@Tom: It just says "Dell Touchpad" -- it's the one that comes on a Latitude E6500. –  Billy ONeal Mar 31 '11 at 14:19
    
@BillyONeal: Here are the most recent drivers: support.us.dell.com/support/downloads/… –  Tom Wijsman Mar 31 '11 at 14:22
    
@BillyONeal: Alternative, that mentions your specific laptop: drivers.softpedia.com/get/Other-DRIVERS-TOOLS/Others/… –  Tom Wijsman Mar 31 '11 at 14:27

Sounds like your graphics card believe it or not. Your card seems to be having trouble keeping up. You can try updating your graphics drivers or trying a new video card. Adobe has a smooth scroll which may cause issues with some older cards especially.

share|improve this answer
    
Is there a way to turn off the smooth scrolling? It's a laptop graphics card so I can't just replace it. –  Billy ONeal Mar 15 '11 at 22:22

The above suggestions, while comprehensive, were not the culprit when I encountered this a few years ago (and just now). I just remembered how to fix it....

Click on View > Page Display > Enable Scrolling

share|improve this answer
    
Adobe Reader just started doing that super-slow scrolling. This fixed it :) –  MrFusion Aug 29 '13 at 4:20

For viewing, there are alternative products that are much faster than the bloated Acrobat.

The fastest I know is Foxit Reader, which I use myself.

share|improve this answer
3  
Unfortunately, such "alternative products" don't work with a bunch of the PDF features. –  Billy ONeal Mar 31 '11 at 14:15
    
@BillyONeal WHAT ? Foxit is the best out there ... and Supports almost ALL features ... but harrymc It is not fast a lot ... –  UltraDEVV Sep 23 at 6:07

I had the same problem. Tried changing the settings listed in other responses to this post. It wasn't until I disabled "enable protected mode at startup" that Acrobat Reader X scrolled and zoomed acceptably. I think my Company had this mode enabled by default in the install, and it cripples the functionality of the application.

share|improve this answer

Your graphics card can't handle the graphics. :( It might be that it's in some power-saving mode, like ATI's PowerPlay or NVIDIA's PowerMizer -- try seeing if that's the case first.

If not, go to Edit->Preferences and try changing:

General->Check 2D graphics accelerator

Page Display->Use smooth scrolling

share|improve this answer

If you would like to try alternatives that might be faster the Adobe have a look at

http://pdfreaders.org/

evince and okular are very good. I find them to be much faster then Adobe. They don't handle things like pdf forms but for most other pdf files they are much faster loading up and running.

share|improve this answer

Are you running Windows or a flavour of linux? I ask this because different drivers will sometimes become slow and outdated. I had a similar problem with my netbook remix version of Ubuntu -- the scrollpad was borked and needed to be reconfigured with a newer and better driver.

I don't think it has anything to do with your graphics card as suggested above, as it works well with an external mouse.

share|improve this answer
    
Windows 7 x64. :) –  Billy ONeal Mar 31 '11 at 19:54

Interestingly, this only seems to occur if I use the "middle button scroll" on the laptop keyboard; if I plug in an external USB mouse and scroll that way the problem seems to go away.

This sticks out to me. Make sure your USB mouse is disconnected, then go into Control Panel, select "Mouse" (you can search for it in the top right), choose the "Wheel" tab and change the "Vertical Scrolling" option to "One screen at a time". See if that helps.

share|improve this answer
    
No better. Now it just instantly scrolls through entire 20 page documents after scrolling for less than a tenth a second. –  Billy ONeal Apr 6 '11 at 6:11

I had this issue on a Lenovo laptop. I fixed it by adding an exception for acrodr32.exe to Universal Scrolling in the mouse advanced properties.

  • Go to Control Panel » Hardware and Sound » Devices and Printers
  • Open Mouse» Lenovo » Advanced Properties
  • Open Wheel » Exceptions and click Add
  • Browse to AcroRd32.exe
share|improve this answer

I had to change the Framerate Threshold for the program to be responsive again. Preferences > 3D & Multimedia > Framerate Threshold. I changed it do 40 FPS and the program seemed to run just fine.

share|improve this answer

Go to Preferences in Adobe Reader, 3D and Multimedia, and change preferred renderer from DirectX 9 to software. That should fix your problem.

share|improve this answer

Try and scroll not by mouse wheel but by dragging the slider on the scrollbar. You'll see that there's no problem at all, scrolling is perfectly snappy and fast.

Thus, this problem is related to the translation between mouse wheel and program, it is NOT a graphics card or Adobe Reader performance problem.

share|improve this answer
    
I was not using a mouse wheel. (I have long since gotten rid of the laptop where this was a problem though) –  Billy ONeal Apr 3 at 19:04

That worked for Adobe Acrobat 9:

[...] I haven't found a solution, but I have discovered that turning automatic scrolling ON and OFF (View>Automaticall scroll or Shift+Ctrl+H) temporarily solves the problem, but only for the currently visible document. [...]

Answer found on Adobe forum

share|improve this answer

click start > control panel > ((in control panel window, look for "Mouse" > ((mouse properties window will pop, click "WHEEL" tab > raise the value under the "VERTICAL SCROLLING" save and check if it is to your liking. repeat until you find what speed you are looking for,.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.