Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do you get RHEL6 to display the "traditional" display of startup information instead of the tiered/stacked progress bar?

The standard info dump is displayed during shutdown.

share|improve this question
    
The same occurs in Fedora and should not be limited to RHEL6. –  DragonLord Jan 19 '12 at 17:56
    
@DragonLord - haven't dealt with Fedora - but will add the tag for future reference –  warren Feb 10 '12 at 15:33
    
Just hit the ESC key the moment the bar show up. –  user270029 Nov 6 '13 at 20:11

5 Answers 5

up vote 7 down vote accepted
plymouth-set-default-theme text
/usr/libexec/plymouth/plymouth-update-initrd

or, remove "rhgb quiet" from the Grub configuration (/boot/grub/menu.lst).

share|improve this answer
    
On a fresh install of Scientific Linux 6.5, with 'quite' removed from kernel cmdline (but 'rhgb' kept), the 'text' theme didn't show any log text, but the 'details' theme did. –  alexei yesterday

The program that shows you the fancy loading screen is called Plymouth.
See if you can find it with checkconfig --list, and disabled the service if needed.

If that isn't the cause, it's probably the "quiet" option in Grub. Disable it by removing the word quiet from the boot options in your /boot/grub/menu.lst file.

share|improve this answer

If you boot in text mode which is how most servers would be set up you have to do still more. In text mode, plymouth paints a colorful text bar which is difficult to completely remove. It's NOT in chkconfig. Here's how.

1) Remove rhgb and quiet from the "kernel" line(s) in /boot/grub/grub.conf

2) Remove or comment out the splashimage and hiddenmenu options.

3) Type plymouth-set-default-theme details

4) Type /usr/libexec/plymouth/plymouth-update-initrd

5) Restart and see if it works.

On the bright side the boot time messages are all saved in /var/spool/plymouth/boot.log and /var/log/boot.log.

When I think about it a little more, I realized that since I'm usually not in front of the server's screen anyway, the plymouth system is not a terrible thing. However, when I'm debugging startup problems when I am in front of the server's screen, plymouth is a nuisance that should have been made easier to remove.

share|improve this answer
    
steps 3 and 4 can be combined into a single operation: plymouth-set-default-theme details --rebuild-initrd –  hakamadare Apr 13 '12 at 15:12

Actually, removing rhgb, which I presume stands for "RedHatGraphicalBoot" solved this issue for me on CentOS6.

Just add this line to your post install ks.conf script:

#Save original, just in case
rsync /boot/grub/grub.conf /boot/grub/grub.conf.orig
#edit and output to /tmp/grub.conf
cat /boot/grub/grub.conf |sed -e s/rhgb// > /tmp/grub.conf 
#replace & remove temp
cat /tmp/grub.conf > /boot/grub/grub.conf ; rm -f /tmp/grub.conf
share|improve this answer

Or in one line (less maintenance and at least as easy to understand):

sed -i .orig s/rhgb///g /boot/grub/grub.conf

Creates a backup first, and edits the file inline.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.