Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am working with RHEL6 inside VMware Workstation. I have already looked here and here, but am still running into a very annoying wall.

I want to have the network adapter on my VM get a DHCP address from my router on my home network (ie, using Bridged networking). The router is set to hand out plenty of addresses:

dhcp settings

and has only issued 5 so far:

client listing

However, I am still seeing the following when I boot into the VM:

eth0 failure

My /etc/sysconfig/network-scripts/ifcfg-eth0 file:

enter image description here

What am I missing? It can't be this hard to get a VM to work. Setting the network adapter to NAT instead of Bridged works fine.

VMware's network settings:

bridging settings

share|improve this question
    
If you set a static IP address does it work? –  Majenko Mar 15 '11 at 18:24
    
Are you using the latest kernel release for RHEL6? –  John T Mar 15 '11 at 18:25
1  
If static doesn't work then it is most likely the configuration of VMWare's bridging. Check you have VMWare set up to bridge to the right interface on the host OS. (what is the host OS anyway?) –  Majenko Mar 15 '11 at 19:54
1  
@warren in the dropdown for VMWare's network settings, where it says bridged to:, set it to your wired ethernet adapter and plug a physical cable into the machine. Does that make a difference? –  John T Mar 15 '11 at 22:13
1  
@warren you're most welcome :) –  John T Mar 18 '11 at 0:11
show 3 more comments

1 Answer

up vote 6 down vote accepted

Problem found, thanks to @John T's comments.

I also have VirtualBox installed, and the auto-bridging feature of VMware Workstation won't pick one of my built-in adapters because they're now labeled "VirtualBox Bridged Networking Driver Miniport" at the end instead of just the built-in names.

automatic settings

If I manually select one of the physical adapters to use for bridging, it works just fine. However, apparently because VirtualBox is doing some form of processing on the connection, it is more sluggish running bridged than NAT-ed.

I am going to remove VirtaulBox from this machine as soon as I do not need one specific VM I have running in it to accelerate VMware's network performance.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.