Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently formatted my laptop for Windows 7. I again reinstalled Windows 7. Before installing again I had copied few pics that were in C:/. Now after I have reinstalled Windows 7 , I am unable to access the same. The error says that I do not have permission to open the file.

Further more I'm not able to copy it back on my hard disk .. The message box pops up stating

You will need to provide administrator permission to copy this file

What can I do?

share|improve this question

4 Answers 4

Set your user account as the permission holder for it via the Command Prompt. Run CMD as an Administrator and run this command, editing it as needed for your files.

cacls *FileName* /t /p *User:Permissions*

Replace FileName with the location of your pictures.

Replace User with whatever your username is.

Replace Permissions with one of the following values:

n : None
r : Read
w : Write
c : Change (Write)
f : Full Control

Here is an example of what you should write to have full control to the folder and all its files and subdirectories.

cacls C:\Users\klutch2\Pictures /t /p klutch2:f

If there are any spaces in the FileName or Path, make sure that you put the directory in between quotes, i.e. "C:\Users\klutch 2\My Pictures\"

share|improve this answer

you can go into Control Panel, select Manage User Accounts, then click Manage User Accounts. Select the user account you wish to upgrade to an Administrator, click Properties and select the Administrator option, and press OK

It may ask that you log off and back in again for it to apply to your account. But then you should be all set.

share|improve this answer

Are you using the administrator account (the first that has been created when you reinstalled the application)?

In that case, you should not have to provide a password, just confirm access to the files. In the other case, you should be able to access it with the primary account.

share|improve this answer

Try opening Explorer through the start-menu with a right-click "Open as Administrator", then you should be able to copy the files and change the owner/permissions in their properties.

share|improve this answer
    
This does not work for explorer. –  Mark Sowul Mar 16 '11 at 20:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.