Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've read the similar question on wireless connections dropping, but no answer seems to apply to my case

I have configured the wi-fi lan of my router to broadcast sid and use WPA-PSK. Every few minutes my wi-fi connection drops for a few seconds and then restores.

When I use two computers and run a ping -n 50000 on both computers, I see that the connection drops at different times but with almost the same rate.

the router is a zyxel, one pc runs windws vista and uses a USB wi-fi device from Belkin: F6D4050 the other one runs windows 7 is a Dell PC with an Intel(R) WiFi Link 5100 AGN

there are no other wi-fi lans around

Update:

I've tried to change channel. Nothing changed.

I've opend the wi-fi (removed WPA-PSK and encryption) and the connection was stable.

I've upgraded the router firmware to the latest version, but enabling WPA-PSK continues to show a connection loss every few minutes.

Next step is timing intervals to see if there is any relationship with WPA-PSK parameters.

By the way: the router is a Zyxel P-660HW-D1 and the firmare version is

V3.40(AGL.9) | 12/07/2009
share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

The problem is the Re-authentication parameter of the WPA-PSK configuration on the zyxel

found that ping dropouts intervals matched this parameters, googled adding parameter name and I found

It seems when using WPA-PSK that the client needs to re-authenticate at a set interval. See Pic

users.tpg.com.au/adslxafq/1/zyxel.jpg

The default time is 1800secs which equates to every 30mins. You can change this to a maximum of 9999secs but it still means you will drop roughly every 2hr45mins.

To overcome this I just changed to WEP as it does not need to re-authenticate. I haven't had a drop out since.

here: http://forums.whirlpool.net.au/archive/310614

share|improve this answer
    
WEP is also insecure. –  Corey Ward Apr 2 at 20:26
add comment

I have had issues on routers where one variant of WPA-PSK (TKIP or AES) causes drop outs. Try without security and then with each variant.

Do you get drop outs if only one PC is connected?

Are the PCs within a comfortable range? I have had drop outs caused by PCs sitting on edge of range with a weak signal.

Not clear on what you were pinging. Is it only one or both of the PCs that are dropping out? Try pinging the router ip from each. Do both drop?

Have you checked if the router has a firmware update?

share|improve this answer
    
I have drop-outs even if only one pc is connected. The server I'm pinging is my internet provider's. But the result is the same if I ping the router. The router and the PCs are very close, the signal is very strong. I'm going to change the security and check the firmware version. –  sergiom Mar 16 '11 at 23:17
add comment

I had a similar situation in the past and tracked it down to bad wifi in my router (don't know if it was merely the antenna or card). Replacing the router resolved it for me. It took me a while to realize it was a problem of the router though. Ping tests can help reveal if there is an actual break in the packet flow, but not the cause of it.

If you're running a ping test, are you merely having each computer ping the other, or from both computers to the same IP on the internet or your intranet? If the two computers are pinging just each other, then it's possible that the wifi on one of the computers is bad. Try the ping from both machines to either your router's IP, or the same public IP on the internet (4.2.2.2 which is one of Google's public DNS adresses would work).

If it's the router, try moving it to a different location in the house/room to eliminate possible environmental factors. Also check the logs on the router and see if they reveal the wireless broadcast information (may be a problem in wireless broadcast). If it's determined to be the PC with the USB wireless you can try using the adapter on another computer to see if you get the same effect there.

Unfortunately, if it's not environmental, it may be that either the wifi adapter in one of the computers is going bad, or the router is. In that case, you may be looking at a replacement purchase.

share|improve this answer
    
The router and the PCs are very close. The signal is very strong. The problem happens even when both or only one of the computers are switched on. The ping target is one server of my internet provider. But connection interruptions are independent. When a pc lost the connection, the other one pings the server without packet loss and vice-versa. What was the brand of the router you had to replace? –  sergiom Mar 16 '11 at 23:28
1  
@sergiom The router I had to replace was a belkin router, only belkin in your setup is the USB adapter, doubt that's the problem (since both machines can lose pings). –  Matrix Mole Mar 17 '11 at 0:09
    
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.