Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just rebuilt my gaming computer a few days ago. These are the specs:

8 gigs of RAM

3.2 GHz AMD Phenom II X4 (unlocked to quad core)

ASUS M4A79XTD

Nvidia 2500 Gts

The RAM passes mem test and the CPU passes prime 95 (no overclocking, I just wanted to see if the unlock cores were stable). For gaming this machine should do really well and it does for the most part. In MW2, the controls are extremely twitchy, even if I am not moving the mouse. The fps is good, and there are no other issues. See for yourself: http://www.youtube.com/watch?v=_V_zZFig66U

That video was taken with a fresh Windows install (with latest drivers). Now upon further testing not all my games do this.

Games that fail: MW2, world at war, fallout new vegas

Games that work great: crysis (at highest settings), AVP (on dx11), mass effect 1 & 2

I don't under stand how this is happening or how to fix it. I even stress tested my gpu using furmark and it passed. Does any one have any ideas?

EDIT:

The game still twitches even when the mouse isn't plugged in

EDIT2:

The twitching only seems to happen if a gun is drawn. In areas where you can't have weapons the mouse is fine

share|improve this question
    
what do you mean by unlocked to quad core? The X4 at the end means it is a quad core by default. –  Kyle Mar 16 '11 at 19:36
    
That is how it shows up now. When I bought it, it was X2 –  CountMurphy Mar 16 '11 at 19:37
    
Ah I see (extra characters) –  Kyle Mar 16 '11 at 19:38
    
@Kyle, not sure what you mean by extra characters –  CountMurphy Mar 16 '11 at 20:41
    
There is a 15 character minimum on comments, I was just making up the space.. –  Kyle Mar 16 '11 at 20:43
add comment

2 Answers

up vote 1 down vote accepted

I found the problem! It was hardware related. So as I mentioned before I had unlocked 2 cores on my cpu. While they did pass prime 95's torture test they were the source of the jumping in MW2 and other games. Went to the bios and turned off the extra 2 cores and viola, everything is as smooth as silk. So I think by default I will keep the cores on, and when I play one of the trouble games I will disable them. Very easy to do. Thank you all for your help :)

share|improve this answer
add comment

Try adjusting the mouse sensitivity in these games, as well as unplugging the mouse while the game is on. It might be a small amount of inaccuracy that is ignored in most games, but caught in your twitchy FPS engines. Also, if possible, try another mouse and/or mousepad. I've seen certain mousepads cause strange issues with optical mice.

share|improve this answer
    
I can adjust the dpi of my mouse on the fly (nice gaming mouse), no effect. Tried another mouse a few minutes ago, no effect. About to try a new mouse pad. Post when I have results –  CountMurphy Mar 16 '11 at 19:39
    
mouse pad had no effect –  CountMurphy Mar 16 '11 at 19:41
    
Looks like this might be an issue due to windows' mouse acceleration, and its hit a LOT of MW2 players. Looks like this fix tends to work, though: gamebanana.com/tools/717 Also, other fixes for this are mentioned in this forum thread: forums.steampowered.com/forums/showthread.php?t=1039073 –  Ryan Gooler Mar 16 '11 at 19:47
    
The First fix had no effect. Cant run the second now as my lunch break is over. although, this sounds like it might be a different issue. In the forums, they have the mouse speed acting crazy at random times. My mouse just twitches like a six year old with a mountain dew IV in its arm –  CountMurphy Mar 16 '11 at 20:04
    
None of the fixes worked :( –  CountMurphy Mar 17 '11 at 0:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.