Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a hard time with a "stuck" left shift key.

my sister complained she is getting symbols instead of numbers using her netbook. after some time I fired up the on screen keyboard (winr+r>"osk") and to my surprise, the left shift key was in some kind of toggle mode.

since then I'm trying to inject registry keys to disable accessibility futures like stickykeys etc. to no avail.

tough luck all http://www.howtogeek.com/howto/Windows-vista/disable-the-irritating-sticky-filter-keys-popup-dialogs/ check box are disabled

What's going on? How can I fix this?

Operating system is Windows 7 Home Premium, SP1.

share|improve this question

5 Answers 5

up vote 1 down vote accepted

Boot to another operating system of your choice (DSL is small), and see if the shift key works as expected. If not, you have a hardware problem (crumbs/soup/coke/coffee in the keyboard?)

Also, if you have a field in your BIOS that lets you type and reflects shift-state, you can use that to test instead of booting to another OS.

share|improve this answer
    
thanks guys for the great replays. the netbook i was using has some form of instant on OS that i used to check the problem. it was there so i connected an external keyboard and problem is not showing on that so i suspect it is a hardware problem. thanks anyways. –  yoshco Mar 17 '11 at 8:01

SharpKeys may help.

share|improve this answer
    
this might be my last hope, i'll just disable the left shift alltogther. but being an international user i need the Lshift+alt combo. –  yoshco Mar 17 '11 at 8:06
    
@yoshco: I found another solution that seems to fix exactly what you're describing -- take a look at my other answer. –  Mehrdad Mar 17 '11 at 8:39

The problem may have to do with the BIOS of the motherboard of the computer.

When the computer first boots up you usually get a splash screen that says Press [key] to enter Setup. Oftentimes the key is F1, or F12.

Inside the BIOS screen there can be a 'keys' setup page and you can change the function of certain keys.

I had a similar experience with a laptop where when the computer would boot the Fn key was automatically on and whenever you typed anything on the right half of the keyboard, the secondary function of each key was used instead of the primary function (letters).

share|improve this answer
    
i had the fn key set for 5 sec sticky, disabled it but doesnt change my error. but cool to know, thank you –  yoshco Mar 17 '11 at 8:04

[I think] This might be by design...

Go to Regional and Language options->Change Keyboards->Advanced Key Settings and for To turn off Caps Lock, select:

Press the CAPS LOCK key

share|improve this answer
    
no, it was allready set that way. –  yoshco Mar 17 '11 at 11:43

In most cases, Left Alt + Left Shift switch between Keyboard Language. It can appear that Shift Lock is on. Try That.

share|improve this answer
    
It is not clear how keyboard language switching relates to shift lock. Could you please explain? –  pabouk Oct 17 '13 at 15:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.