Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been having the same problem with Windows Updates on 2 of my machines at home, both running Windows 7 Home Premium 64-bit. One of the 2 machines is a brand new install, the other has run Windows Update in the past, but is also not working now.

When I manually check for updates using the Control Panel, I get error code 8024402F:

windows update error code 8024402F

I followed the link to "Get help with this error", which brings up several articles in Windows Help and Support, none of which are for this specific error code. From the help and general googling I've tried:

  • Checking internet connectivity. Most of the help suggests that this error is caused by a general internet connectivity problem. But if you're reading this, my connection is definitely working fine.
  • Disabling antivirus temporarily and trying to run Windows Update. This didn't help (I run AVG free)
  • Running Control Panel -> Troubleshooting -> Security Systems -> Fix Problems with Windows Update. This said it detected and resolved problems, but didn't help.

windows update troubleshooter results

internet explorer windows update not reachable

I've had the same problem for 24 hours now, so surely the Windows Update servers haven't been down this whole time? A quick check on twitter shows no worldwide outcry about Windows Update being unavailable, so is it just me? I'm based in the UK, but I notice that the URL is also unavailable using ''wget'' from my webserver in Chicago.

day@ord1:~$ wget
--2011-03-17 00:01:27--
Resolving failed: Name or service not known.
wget: unable to resolve host address `'
day@ord1:~$ host
Host not found: 3(NXDOMAIN)

Edit: Output of ''ipconfig /all'':

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Office
   Primary Dns Suffix  . . . . . . . : 
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : home

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Intel(R) 82566DC Gigabit Network Connection
   Physical Address. . . . . . . . . : 00-1C-C0-71-89-46
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::a17f:ec64:9b37:92b9%11(Preferred) 
   IPv4 Address. . . . . . . . . . . : 
   Subnet Mask . . . . . . . . . . . :
   Lease Obtained. . . . . . . . . . : 17 March 2011 00:25:47
   Lease Expires . . . . . . . . . . : 18 March 2011 00:25:48
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 234888384
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-10-68-D4-00-1C-C0-71-89-46
   DNS Servers . . . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.home:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:2098:13b8:a9ec:3703(Preferred) 
   Link-local IPv6 Address . . . . . : fe80::2098:13b8:a9ec:3703%13(Preferred) 
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

Edit 2: Suggestions from Microsoft Support:

Configure the connection to obtain an IP address automatically

  1. Click "Start", input "NCPA.CPL" (without quotation marks) to Start Search bar and press "Enter".
  2. Right-click the network connection and click "Properties". If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
  3. Click to highlight "Internet Protocol Version 6 (TCP/IPv6)" and click "Properties".
  4. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".
  5. Click "OK".
  6. Click to highlight "Internet Protocol Version 4 (TCP/IPv4)" and click "Properties".
  7. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".
  8. Click "OK".
  9. Reboot the computer.

I tried that and IPv4 and v6 were both already set to these settings, rebooted anyway, error still there. I then sent my System Information and WindowsUpdate.log file to Microsoft, sorry but I'm not posting their contents here.

Will keep you posted on progress.

share|improve this question
If you do not get it resolved, get free Windows Update support from… – Moab Mar 17 '11 at 16:50
@Moab Will do thanks – Day Mar 17 '11 at 18:49
Updated with suggestions from Microsoft Support – Day Mar 18 '11 at 13:48

10 Answers 10

up vote 27 down vote accepted


I haven't heard back from Microsoft Support since sending them my log files, but I got some time to take a look myself. Here's a relevant snippet:

+++++++++++  PT: Synchronizing server updates  +++++++++++
  + ServiceId = {9482F4B4-E343-43B6-B170-9A65BC822C77}, Server URL =
Timeout for accelerated install is already set
WARNING: Cached cookie has expired or new PID is available
WARNING: PTWarn: Anonymous plug-in skipped for WU
Triggering accelerated install by calling UpdateNow
No installable updates are available
WARNING: Send failed with hr = 80072efe.
WARNING: SendRequest failed with hr = 80072efe. Proxy List used: <(null)> Bypass List used : <(null)> Auth Schemes used : <>
WARNING: WinHttp: SendRequestUsingProxy failed for <>. error 0x80072efe
WARNING: WinHttp: SendRequestToServerForFileInformation MakeRequest failed. error 0x80072efe
WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x80072efe
WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x80072efe

Note the failure to download

I tried to download this CAB file from a browser, which didn't work. I then tried wget (in cygwin) which didn't work and reported "Connection reset by peer". I also had the same problem downloading the CAB file from Linux machines on my home network, so it was not an issue with the Windows machines themselves.

To cut a long story short, I finally tracked down the problem to my router, which is running DD-WRT.

Apparently I must have enabled the "Filter ActiveX" option about a month ago and forgotten that I'd done so.

enter image description here

Given the security problems with ActiveX, this sounds like a sensible option to activate, but upon reading the help... not so much!

Filter ActiveX Blocks HTTP requests containing a URL ending in ".ocx" or ".cab".

Yes... that would certainly cause problems! Unticking this and applying the settings to the router has cured the problem on both of my Windows machines, as you'd expect.

Thanks everyone for your help & suggestions, hope this is of use to someone else.

share|improve this answer
I resolved my issue by changing my DNS server settings to point to the google DNS servers: and – Populus Oct 26 '12 at 10:07
Genius! Thank you. I had the same issue with my router and completely forgot about blocking ActiveX. – Neil Jul 30 '13 at 18:48
Wow, this seems like a serious lack of research on the part of the DD-WRT guys. I can see blocking .ocx, but .cab files are used by a lot of software on Windows. I would consider reporting this as a bug in DD-WRT. – Jonathon Reinhart Feb 3 at 10:35

Go to Internet Explorer, Tools, Internet Options, Connections, Local Area Network (LAN).

Settings: If it's set to "automatically detect settings" switch it to "Proxy server" (my Windows 7 machine says port 80).

Then try Windows Update, it should work now.

If your machine is set to "proxy server", switch to "automatically detect settings" and try again.

share|improve this answer
Unchecking “Automatically detect settings” under Internet options/Connections/Lan settings did the trick for me as well. It started to download updates immediately. Also the did work after this change. – user117551 Feb 9 '12 at 8:58

I managed to solve this problem by switching from "Obtain DNS server address automatically" to "Use the following DNS server addresses" and entering "" and "". These are public DNS servers from Google:

share|improve this answer
When I tried this in Vista Home Basic, it told me that those network addresses were invalid. – Paul D. Waite Apr 21 '13 at 16:41
Ah - I think they are invalid for IPv6, but they worked fine for IPv4. So I unchecked IPv6. And now Windows Update connects fine. Hopefully I can switch back to automatic DNS once the updates are done - it worked fine until Service Pack 2 was installed and Windows Update updated itself. – Paul D. Waite Apr 21 '13 at 17:00
Using DNS fixed the 0x8024402f error immediately for me (I have had the error for ages, last updated 6/6/2013). The Windows Update Troubleshooter always says it has fixed a problem, but it did not fix the problem. I already had IPV6 disabled. – robocat Jul 18 '13 at 1:21

Click on your time and date (bottom right). A window should pop up, click on the link 'change date and time settings'. On the date and time window click on the internet time tab, click on Change settings button, then click on the 'update now' button, then click ok and exit the windows and now try your windows update.

share|improve this answer
A truly bizarre answer, is there a knowledge base article or similar that prompted you to suggest this? I tried it, but it didn't work I'm afraid. – Day Mar 18 '11 at 13:44
Albiet a bizarre answer, a lot of Microsoft technologies rely on time. For a specific example: Active Directory - if the client's clock is different than the server's clock bad funny things can/will happen. – Nathan Adams Mar 18 '11 at 23:08
It's not just Microsoft technologies. Active Directory uses Kerberos (an open source protocol) which uses time to express ticket expiration. – Jonathon Reinhart Feb 3 at 10:31

Couple of things - You no longer use IE to perform updates in Windows 7 (and Vista?), in fact I don't think the "correct" URL is I believe it is and just sends you to a page saying "Hey, you can't use this anymore!" .... but that is beside the point and I digress (alot).

I don't know how much information your willing to post but one place I would start is from your Windows box type:

ipconfig /all

And check the output for anything odd. Awhile back I had a client who had issues getting Windows Updates, turned out someone hacked/messed with her router and changed DNS settings.

What updates are you trying to install? I know SP1 has an "issue" with dual boot systems and some systems that don't have a system partition (but either is easy to fix).

share|improve this answer
Not using IE: fair enough, was just casting about for other options. Will check ipconfig and post if enlightening. Not trying to install any particular update - was just trying to run update for first time on the newly installed PC, which didn't work and led me to find out that it was also now broken on my older install on the laptop which used to work fine. – Day Mar 17 '11 at 0:24
Have added ipconfig /all output. Looks fairly sane. – Day Mar 17 '11 at 0:38

Sounds like a corrupted update repository. Try this:


Stop the "Background Intelligent Transfer" and "Windows Update" services.

Start-->Cmd ('as administrator')

rd %systemroot%\softwaredistribution /s

Go back to services and start Windows Update service.

Try updates again.

share|improve this answer
Didn't help I'm afraid. At least not on the laptop. Will also try on the desktop. Would be odd if both had got corrupted at same time... but you never know ;) – Day Mar 17 '11 at 0:28
No joy there either. Thanks anyway – Day Mar 17 '11 at 0:41
@Day: NP it's always a good frist step. – Ƭᴇcʜιᴇ007 Mar 17 '11 at 12:02

I would recommend reading this article and following step by step (including the tools). I wasn't able to solve the issue by any of the other answers of this thread until I read the article.

How to solve connection problems concerning Windows Update or Microsoft Update

The article includes a Connection error code list, download links to the tools, CMD commands, etc. for Windows XP, Vista, 7, 8 & 8.1. It's really complete. I was able to solve my issue with it.

share|improve this answer

Just got hit by this one. This happened right after I made a HotFix install (hotfix which did not say anything about rebooting...)

The problem was fixed just by rebooting the system and making sure my VPN was turned on.

Now that Firewall configuration is not bad if you're just running Linux!

share|improve this answer

Well, disabling IP6 in the network connection properties, worked for me. I hope it does for you too !

share|improve this answer

I had a very similar problem documented here and all the possible solutions listed in this question didn't work.

It turned out the problem was the .NET Framework 4 Client Profile and that replacing it with the .NET Framework 4.5 made the Windows Update error go away.

share|improve this answer

protected by slhck Feb 15 '12 at 15:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.