Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is it possible to copy hibernation or paging file on a live system? I tried to use Hobocopy.exe like this:

hobocopy.exe c:\ c:\temp hiberfil.sys

but it does not work. Using the same hobocopy and the same syntax, I am able to copy registry files (e.g. SOFTWARE file). Does hiberfil.sys differ and "locked more" by a system? Is there any way to copy these two files except for rebooting in recovery mode?

share|improve this question

migrated from stackoverflow.com Mar 17 '11 at 0:48

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I'm guessing this is a permissions problem, and that even administrators don't have permissions to access this file. Shadow copies of files have the same ACLs as the files they shadow.

What's the particular error you're getting? Can you try

hobocopy /verbosity=4 C:\ C:\temp hiberfil.sys

And comment with the results? Assuming it's error 5, you're going to have to either change permissions on the file or run hobocopy as a user that has access permission. Presumably that's SYSTEM. One way to run things as system (there are several) is to use the psexec program and specify the -s option. Something like this:

psexec -s hobocopy C:\ C:\temp hiberfil.sys

You can get psexec from http://technet.microsoft.com/en-us/sysinternals/bb897553

share|improve this answer
    
Thanks, Craig. Indeed, the initial error was 5. However, using psexec did not help. It now issues error 0 but nothing is copied: Starting a full copy from C:\ to L:\Temp\h Copied directory Backup successfully completed. Backup started at 2011-03-17 01:05:15, completed at 2011-03-17 01:07:16. 0 files (0.00 bytes, 1 directories) copied, 2727 files skipped –  Alex Mar 16 '11 at 22:10
    
Weird - it's almost like it didn't match the name of the file. Can you verify that the file is spelled correctly? Also, I'd love to see the output of psexec -s hobocopy /vebosity=4 C:\ L:\Temp\h. –  Craig Andera Mar 17 '11 at 11:33
    
Also, it might be best to move this conversation to hobocopy@googlegroups.com, since I don't always remember to check back here. –  Craig Andera Mar 17 '11 at 11:34
    
I thought of another idea: try psexec -s hobocopy C:\ C:\temp *.sys just to see if it can match by wildcard. –  Craig Andera Mar 17 '11 at 11:35
    
Is it possible to tell hobocopy not to go through subfolders, something like /norecurse? It takes too long to wait for its completion especially in verbose mode while I only need to copy a single file. –  Alex Mar 18 '11 at 8:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.