Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 11.10 with Gnome Shell and unity and I was wondering how to change the desktop wallpaper form terminal or command line .

I found the following but i can't seem to get it to work ,

gconftool-2 --set /apps/compiz/plugins/wallpaper/screen0/options/images --type list --list-type string "[file:/path/to/first.png:100,file:/path/to/second.png:100]"
share|improve this question
Do you get an error message? I don't know if this is your problem, but the man page says that the key name is a parameter, not an option, so you should try putting it after the options, e.g. gconftool-2 --set --type list --list-type string /apps "[file...]". – Mikel Mar 17 '11 at 3:26
up vote 1 down vote accepted

I would do this if I were you: gsettings set org.gnome.desktop.background picture-uri file:///path/to/img.jpg (tip from here)

share|improve this answer

I would try this:

$ gconftool-2 --type list --list-type string --set /apps/compiz/plugins/wallpaper/screen0/options/images "[file:/path/to/first.png:100,file:/path/to/second.png:100]"

It successfully sets that key/value for me:

$ gconftool-2 -R /apps/compiz/plugins/wallpaper 
   bg_color2 = []
   bg_image_pos = []
   bg_fill_type = []
   images = [file:/path/to/first.png:100,file:/path/to/second.png:100]
   bg_image = []
   bg_color1 = []
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.