Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I store name.sh under C:\Documents and Settings\user when i type sh name.sh in Cygwin,

sh: testing.sh: No such file or directory

any help will be appreciated!

share|improve this question
    
Please don't cross-post. – Dennis Williamson Mar 17 '11 at 5:46

Is that the actual output? If so, it's looking for another script called testing.sh.

testing.sh needs to be in a directory listed in the PATH variable, or you have to run it using a full path, e.g. ./testing.sh or ~/user/testing.sh.

Also don't forget to make testing.sh executable by running chmod +x testing.sh.

share|improve this answer
    
Sorry,actually there is only name.sh involved, typing error – Lily Mar 17 '11 at 6:12
    
That's OK. It's easy to make mistakes when typing. That's why it's better to always post the actual output. Or if you need to hide some sensitive information, copy paste into Notepad, do a Find/Replace, then post that. – Mikel Mar 17 '11 at 6:21

If you're in C:\Documents and Settings\user when you're running it, try:

./name.sh

If you're not in that directory, you'll need to either change directory there or prepend the command with the location. Here's how to change directory to c:\documents and settings\user

cd /cygdrive/c/"Documents and Settings"/User

You can see which directory you're currently in with the following command, I believe:

pwd
share|improve this answer
    
I think you may have missed the fact that there are two different filenames involved. – Dennis Williamson Mar 17 '11 at 4:40
    
thanks, it works after changing the directory – Lily Mar 17 '11 at 6:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .