Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I get the websites that I visit to stop localizing the language probably according to my IP location? This is an website specific issue because, for example economist.com and superuser.com do not do it, but Google Checkout and craigslist.org are doing it. Is there a way to setup Ubuntu and Firefox so that English will always be used for all web pages displayed?

Edit: Of course many webpages have a link to an English version, but sometimes they don't. For example I believe such links usually appear on the root resource but sometimes I see non-English languages on child resources where such links do not appear. Example: most Blogger.com blogs appear in English but when I go to the blogger's profile ("view my complete profile"), it appears in another language that matches my geographic location.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

If the website is using geolocation by IP address, there is nothing you can do – short of setting up a proxy server somewhere in UK or USA.

If the site is using Accept-Language, meinertz's answer applies.

share|improve this answer
add comment

There are some settings in Firefox you can try to mess with. I'm using Firefox 4 on Windows, but i think you should be able to find it in approximately the same place:

Open the options (if you are using ff3 on linux i think it's under Edit -> Preferences...) and switch to the "Content"-tab. There should be some language specific options which you can try to mess with.

share|improve this answer
    
Thanks but File/Preferences/Content/Languages is already set to English. –  broiyan Mar 17 '11 at 10:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.