Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's what worked for over a year: PC A runs Windows 7, PC B runs Windows XP. Both are on the same subnet behind a router. A uses user account X, but logs in to PC B using the Administrator account.

PC B is a Dell Precision 470. A known problem with these is that sometimes when plugging in their power cable they somehow loses all BIOS settings. This happened yesterday. After this happens Windows won't boot, because the default BIOS setting is 'RAID ON' while there is no RAID configured. No problem though, changing the BIOS settings to 'RAID OFF' makes it boot without problems. Note that in the meantime, nothing config-related was changed on machine A. It wasn't even on.

Indeed after doing this, everything is fine. Everything includes all normal operations, remote desktop from PC A to PC B, running Synergy between A and B, accessing shared folders from B to A. But accessing the shared folders on B from A does not work any more.

I tried pretty much everything I found via Google (fiddling with policies/registry kes/...) but no avail.

> ping -a 192.168.2.2
Pinging A [192.168.2.2] with 32 bytes of data:
Reply from 192.168.2.2: bytes=32 time<1ms TTL=128

> net view \\192.168.2.2
System error 5 has occurred.

Access is denied.

> net use /persistent:no K: \\A\myshare /user:A\USERNAME PASSWORD
> net use /persistent:no K: \\192.168.2.2\myshare /user:192.168.2.2\USERNAME PASSWORD
> net use /persistent:no K: \\192.168.2.2\myshare /user:USERNAME PASSWORD
System error 86 has occurred.

The specified network password is not correct.

A solution to this would be great: I haven't been able to do any work since yesterday ;]

update after taking the hard drive out of B and putting it in another Precision 470 (let's call it machine C) with almost exactly the same hardware (at first sight, only the video card differs) the shared folders work.. Putting the disk back into B, same problem remains. Why does this depend on hardware, and more important, on which hardware?

update 2 taking the hard drive from machine C and putting it into B, file sharing works, but only if I give 'Everone' permissions to the share. Not via user/password.

Keeping this in mind I tried the same (giving 'Everyone' permissions) with the original machine B, no avail. However if I use 'Simple File Sharing' instead it does work! Seems like there is something really fishy going on in the negotiation of users?

share|improve this question
    
Is there a BIOS password on the HDD, perhaps? –  Steve Mar 18 '11 at 1:53
    
Could this be a CMOS issue on the machine that it continues to be problematic with? –  John 'Shuey' Schuepbach Mar 18 '11 at 5:51
    
@Steve: no BIOS passwords at all @John: that might be the cause; any idea how I can check this? –  stijn Mar 18 '11 at 8:48
    
1) Install Wireshark and tell it to display all smb traffic. Watch session setup messages to make sure your computer is using the right username when connecting. 2) Also enable account logon auditing in PC A (secpol.msc) and watch the security log (eventvwr.msc). 3) Create your own account and stop using Administrator. –  grawity Mar 18 '11 at 20:03
add comment

1 Answer 1

up vote 1 down vote accepted

ok. Found the problem, and the solution. I feel pretty stupid right now because it was so basic and I lost like a day, but on the other hand not that stupid since it was clearly not that obvious:

the date was wrong

seems I accidently set it to May instead of March after the bios screwed it up. Bang.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.