Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having an issue when trying to start the Server service on my machine. I noticed that it wasn't started when I tried to access a share on my machine. I receive an error that states "Windows could not start the Server service on Local Computer. Error 2: They system cannot find the file specified." A snapshot of this error is below:

enter image description here

I've tried doing an "upgrade" of Windows to repair it, but the upgrade fails as it says I already have the latest Windows.

Any idea as to how I can repair this one file?

share|improve this question
Look in the Windows\System32 folder for "services.exe", is it 32bit W7 or 64bit? – Moab Mar 18 '11 at 1:10
Scan for… – Moab Mar 18 '11 at 1:11
up vote 1 down vote accepted
share|improve this answer
1) Tried this and it didn't do anything – Jason N. Gaylord Mar 17 '11 at 21:40
2) No restore points available on this machine. I thought SP1 automatically took one, but apparently not. – Jason N. Gaylord Mar 17 '11 at 21:41
Added 3. You should get a restore point at every windows update, unless you've turned them off, so that's weird. – Ƭᴇcʜιᴇ007 Mar 18 '11 at 2:55

Do you have the file "Srvsvc.dll" in C:\Windows\System32? I believe that's the file it's trying to use to start the service. If it's not there, you got some issue (virus or antivirus deleted it maybe?).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .