Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a dual-monitor setup, and currently I can run a full screen game (Warcraft 3 and Starcraft 2 currently) and see still see anything I have open on my second monitor.

I can't move my mouse from one monitor to the other, which is a good thing. However, I would like to know if it's possible to press some key combination and "release" my mouse control from the full screen game to my second monitor without the game minimizing (which is what happens when I ALT - Tab).

share|improve this question
    
have you considered running the games in maximized windowed mode? –  Xantec Mar 17 '11 at 21:46
    
The only issue I have with maximised windowed mode is that it usually stretches the image of the game rather than resizing the resolution of the viewport. This will often result in slightly distorted images. –  Matthew Scharley Mar 17 '11 at 22:55
add comment

4 Answers 4

up vote 7 down vote accepted

Some games support a Fullscreen Windowed mode along side Fullscreen and Windowed. This is the only way to do this, any Fullscreen application will minimise when you alt-tab.

Some games I know support this mode:

  • World of Warcraft
  • Rift

Some games will let you simulate Fullscreen Windowed mode. There are also probably applications that help with this (EveMon will do this for EVE Online). All Fullscreen Windowed mode really is is the ability for the application to take a normal Windowed version of itself and position it such that it looks like it's running in Fullscreen mode; ie, the window chrome is placed offscreen.

share|improve this answer
    
+1. Anything that's using true fullscreen will minimize when you go out - that's how fullscreen mode works. –  Shinrai Mar 17 '11 at 22:49
add comment

I was looking to be able to do this as well, surf the web/youtube on the 2nd monitor during down time in game . So here's how I did it.

Install a program called Actual Multiple Monitors (free ver.)

  1. Go to the window Settings and "Add a new window rule to the current list"
  2. Now name it and fill out the directory to your game. Mine was

    C\Program files\...\wow.exe.
    
  3. Under your new rule go to the "Startup" tab and check the "Ignore deactivation", Apply and Ok your settings

That should about do it. Your game will not minimize for anything... even if you wanted it to. The key combo (Win`) by default settings will switch you from monitor to monitor.

I am still working on settings to try and get it to minimize when i want it to, but you can always exit the game. Oh and i noticed on the Screen shots it says "pro only" even tho i am using the free ver.

share|improve this answer
add comment

I do this all the time. SC2 at the very least supports full screen windowed mode which allows you to use other windows by alt-tabbing.

share|improve this answer
add comment

In addition to animepunkw's answer

Here is how I fixed it:

In the Actual Multiple Monitors program, you can set a hotkey for "Ignore deactivation on a program". I just set it to Alt+F1. I find this much better and more useful if you need to Alt+Tab for something.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.