Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to send a mail from my Linux (CentOS) server, the exit status is 0, but the mail never reaches it's destination. The /var/log/maillog file has an entry something like this...

Mar 18 06:33:01 app11 postfix/qmgr[22454]: F18FD9F6074: to=<[email protected]>, relay=none, delay=0.01, delays=0/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to alt4.gmail-smtp-in.l.google.com[74.125.45.27]: Connection refused)

Am I blocked by google? I tried to send a mail to some other mail server and got the similar result.

Mar 18 06:33:01 app1 postfix/smtp[15460]: connect to acsinet11.xxx.com[111.222.333.444]: Connection refused (port 25)

How do I correct this problem?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

As mentioned by others port 25 may be blocked for outgoing traffic on your router. Or the receiving server is down or blocked.

Simple try a telnet acsinet11.xxx.com 25 from your server to see if you can reach the other server on that port.

If you get something like:

Trying 111.222.333.444...
Connected to acsinet11.xxx.com.
Escape character is '^]'.
 220 acsinet11.xxx.com ESMTP Postfix (Ubuntu)

then nothing is blocking port 25, however if you only get something like:

Trying 111.222.333.444...

And nothing else then it is blocked by your server, your isp, their isp or their server.

As you can not reach GMail's servers then the problem is most likely your ISP.

share|improve this answer
add comment

Most probably your ISP is blocking port 25. Call to service desk (hopefully you can reach technician who really knows something).

It's also possible that your firewall (if you have firewall at all) is blocking that.

It's unlikely that you are blocked by Google if another server is not working either.

share|improve this answer
    
How do I check the firewall setting? –  shantanuo Mar 18 '11 at 7:30
    
@shantanuo: it depends on your setup. If you have router/dedicated, then typically over serial console or web ui. Try opening your gateway address in browser. Try running sudo iptables -L in your Linux box. –  Olli Mar 18 '11 at 7:31
2  
+1 This is most likely the cause. Some ISPs block port 25 in order to fight spam, some routers/firewalls might block it without you knowing. –  slhck Mar 18 '11 at 7:57
1  
I know many ISPs do block port 25 nowadays or any outgoing SMTP traffic that isn't sent through their mail relay server, which will usually require authentication with your account information. Some that do will only let you send mail if you upgrade to a business level contract, others may let you send for a monthly fee or through a special agreement with them. –  BBlake Mar 18 '11 at 11:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.