Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a BSNL modem, which worked fine with Windows Vista. After I started using Windows 7 Enterprise, I found that I couldn't connect to the net using the modem (keep getting Error 651). It seems like the raspppoe.sys problem that had first been reported on Win7 RC.

My question is, how do I solve this the "official" way - is there a patch for fixing the problem? I've read on many forums that renaming/replacing the original file in drivers/ folder didn't help a lot of users, but since its been at least a year since then, I'm wondering about the official fix for it. Can anyone help?

share|improve this question
up vote 0 down vote accepted

I solved the problem - the "error 651" that had prompted me to replace the .sys file was caused by an issue on part of my ISP, BSNL. Once that had been fixed, the problem went away once I restored the original driver for Win7.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .