Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to share my ADSL Internet connection with another laptop via a wireless network. I created an adhoc network and I turned on Internet Connection Sharing. The security level is set to "open."

The second computer can connect to my network, but it cannot access the Internet. Both operating systems are Windows 7. The second computer is using Nod32 Antivirus, which I suspect is the cause of the problem. I did turn off its firewall and Nod32 protection, but the problem still existed.

What do I have to do to share my Internet connection?

share|improve this question
    
what are dns-servers' and gateway IP on the laptop you share internet to? are they correct? –  Sergey Mar 18 '11 at 16:37
    
@sergey , where have i to set ? i used to internet connection sharing last times and i did not set gateway IP and ... i just created adhoc connection with internet connection sharing . –  shaahin Mar 18 '11 at 16:41
    
i think the problem is because of Nod 32 –  shaahin Mar 18 '11 at 16:48
    
so you had your network working but something happend? –  Sergey Mar 18 '11 at 17:17

1 Answer 1

The easiest solution I have found for wireless networking is to get a wireless router. This allows you to have a dedicated machine that is designed for this very purpose. It also gives you added security of not having your machine directly connected to the internet.

Make sure the wireless card is good by having your laptop connect to a known good hot spot. It could be that a bad device is causing problems. I doubt that your virus scanner is preventing you from connecting to the internet. A firewall could cause problems if it is setup to block outbound traffic. You stated that you disabled both and you still have problems so it is probably a configuration issue. Use tools like ping and tracert to determin what you can talk to. Check your ip settings with ipconfig and make sure that you are getting the correct DHCP information.

If you don't want to do that, then you might try using a third party hotspot tool like Connectify. It can setup your network without you knowing much. Other than that, make sure that you are following the correct steps to create the ICS connection.

Hope this helps,

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.