Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It's a ThinkPad W510, with Windows 7.

I've been struggling with this since I got the laptop. Very often, say for 20-30 minutes at a time several times a day, the laptop gets painfully slow. I'm usually working in Visual Studio, but the slowness isn't isolated to that. Chrome is slow, even opening the start menu is slow. So slow, I can type a sentence in notepad and it won't show up until 5 seconds later.

The HDD light is flickering during this time, usually. I have tried to figure out what process or service might be using the CPU, but even at its worst, there's only about 20% usage from other processes (spread across a few that don't surprise me). One suspect process is svchost.exe which sometimes gets up to 15% usage, but when I use Resource Monitor to see which services are to blame, none really pop up as a culprit -- none go higher than say 6% for very long. Still, I've shut down a lot of services in an attempt to figure it out. But it hasn't had any effect. Since the CPU doesn't climb to 80% or anything, it seems the problem isn't CPU usage, but some other bottleneck (hdd? some kind of lock? handles?)

What's really interesting is that while the slowness is occurring, if I unplug the laptop from the AC power, it goes away almost instantly! Apparently, whatever is causing the problem is setup only to run while on AC power.

I guess what I'm looking for from here is ideas on how to better identify the problem. My dabbling in resource monitor and sysinternals process monitor is not really helping. What should I be looking out for?


My problem turned out at least partially to be due to 'CPU Parking'. Windows 7 has a feature where it can 'park' CPUs to save energy. I've disabled it via a reg hack and I haven't had the problem since. I still have slightly higher CPU usage while plugged and I haven't figured out why since no one process seems to be to blame, but now it doesn't slow the computer down.


Turned out I still had problems even with CPU parking disabled. The real problem turned out to be that I was using a 90W power supply, and the thinkpad's power management mistakenly thinks this is not enough power and slows the CPUs down to save power. Using the 135W power supply fixes it. Some people have other suggestions, even a hardware hack:

share|improve this question

Windows 7 has "Power Options" that could be affecting your performance. To check for this click on the start button, go to control panel, and click on "Power Options."

Power Options Icon in the Control Panel

Now, make sure that the "Show Additional Plans" button has been selected, if it has, it will say "Hide additional plans." Click on the "High Performance" power plan. You can also go into the plan and change settings for optimal performance.

High Performance Power Plan Selection

share|improve this answer
Thanks -- I have poked around in power options, too. It wasn't set to the High Performance option, but nothing in the advanced view looked suspect. I'll try 'High Performance' and see what happens after a while... – InfinitiesLoop Mar 18 '11 at 21:52
As a follow up -- I'm still having the problem despite on 'high performance'. So... still not solved. – InfinitiesLoop Mar 22 '11 at 19:25

The power management tips above are aces in terms of trying to get your machine to work well. You might also find these tips on conserving your battery to be helpful as well:

share|improve this answer

I sometimes experience this extreme slowness when i unplug the pc and plugs it back in again. To remedy the situation my workaround is to unplug the pc and let it run for at least 10 seconds. Then put it on standby, plug in the power-cord and let it wake up with power on. Then it will run at full speed again.

share|improve this answer

I solved a similar problem by going to the global settings tab of the power management Thinkpad app. There I was able to disable some CPU slowing features. The trick is finding every Thinkpad CPU slowing feature and disabling it.

share|improve this answer
Could you add more details about which settings to change and where to find them? – zeel Feb 11 '15 at 20:18

Out of all the reviews, formus, and post about this problem, I never saw anyone go into the BIOS. I see where everyone updated drivers, change reg settings, used different power bricks, and even modified their internal cable to "fool" the low voltage.

1) restart your computer 2) Press "enter" at the Think screen. 3) Press "F1" at the menu to goto BIOS 4) select "Config" 5) select "Power" 6) Look in this menu. You should see "Intel SpeedStep Tech..." 7) turn Mode for AC to "Maximum Performance" 8) turn Mode for Battery to "Maximum Performance" - Note: you may also turn max perf on for the Thermal Managament aswell 9) F10 to save it and back out.

Restart your computer an enjoy that performance you all have been looking for for the last 5 years. (I know I did)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.