Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At first i thought it was my computer but then i tried chrome. Why isnt firefox not hardware accelerated? The first screenshot shows chrome at 23% usage. The 2nd shows 59%. I have 2 cpus which is why it isnt 100% usage. The game pictured is biolab

chrome Firefox


Heres the text for about:support

Application Basics

    Name
    Firefox

    Version
    4.0

    User Agent
    Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

    Profile Directory

      Open Containing Folder

    Enabled Plugins

      about:plugins

    Build Configuration

      about:buildconfig

Extensions

    Name

    Version

    Enabled

    ID

Modified Preferences

  Name

  Value

    accessibility.typeaheadfind.flashBar
    0

    browser.places.importBookmarksHTML
    false

    browser.places.smartBookmarksVersion
    2

    browser.startup.homepage_override.buildID
    20110303194838

    browser.startup.homepage_override.mstone
    rv:2.0

    extensions.lastAppVersion
    4.0

    gfx.font_rendering.directwrite.enabled
    true

    network.cookie.prefsMigrated
    true

    places.history.expiration.transient_current_max_pages
    127602

    privacy.sanitize.migrateFx3Prefs
    true

Graphics

    Adapter Description
    Mobile Intel(R) 4 Series Express Chipset Family

    Vendor ID
    8086

    Device ID
    2a42

    Adapter RAM
    Unknown

    Adapter Drivers
    igdumd64 igd10umd64 igdumdx32 igd10umd32

    Driver Version
    8.15.10.2202

    Driver Date
    8-25-2010

    Direct2D Enabled
    true

    DirectWrite Enabled
    true (6.1.7600.16385, font cache n/a)

    WebGL Renderer
    Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

    GPU Accelerated Windows
    1/1 Direct3D 10
share|improve this question
1  
Because the Firefox developers didn't implement it? –  Daniel Beck Mar 19 '11 at 6:05

1 Answer 1

Firefox 4 disables hardware acceleration for certain graphics chipsets they feel are unreliable. To check from within Firefox whether GPU acceleration is enabled, type in about:support in your address bar and press Enter. Then look in the Grahpics section. If it's enabled, the lines labeled Direct2D Enabled and DirectWrite Enabled will say true. Otherwise it will say false. This example has hardware acceleration enabled:

Firefox about:support with graphics acceleration enabled

You can manually enable hardware acceleration. To do so, browse to about:config, click I'll be careful, I promise!, and type webgl into the Filter box. Then, just double-click on the webgl.force-enabled property in the lower pane to toggle it from false to true. Close out of Firefox and restart it for the changes to take effect.

Firefox about:config with webgl.force-enabled property highlighted

If you have trouble, you can start Firefox in Safe Mode, either by locating Mozilla Firefox (Safe Mode) in the Windows start menu or adding the -safe-mode switch to the firefox command. Hardware acceleration is always disabled in Safe Mode. You can then perform the above steps to change the setting back to default.

share|improve this answer
    
I edited my question with the copy/paste from about:support. Using setting force to true does not help –  acidzombie24 Mar 19 '11 at 7:12
1  
@acidzombie24: According to your output. hardware acceleration is enabled and working in Firefox. The excess processor usage might be related to differences between Mozilla's SpiderMonkey JavaScript engine and Google's V8. The two browsers are constantly competing to improve speed and I'm afraid resource usage might have been left on the backburner. Also, hardware acceleration is not enabled in Chrome by default. You can enable it by visiting about:flags if you want to test the difference with it enabled. –  Patches Mar 19 '11 at 8:37
    
WTF!?! I enabled HW. How the F is SW faster then HW! I get the same performance as firefox and a blank screen after the logo instead of the actual title screen and game. I implemented 2D rendering in SW before, it was extremely slow (especially with alpha). I dont understand how this performance could happen. –  acidzombie24 Mar 20 '11 at 1:45
    
@acidzombie: "Firefox 4 disables hardware acceleration for certain graphics chipsets they feel are unreliable" –  grawity Mar 20 '11 at 8:46
    
@grawity: I am still WTFing on how SW is faster then HW. Sure FF may disable gfx but the performance 'appears' to be the same with it on. Chrome performance is way better. But... SW cant be faster then HW.... (especially when i can play 3d games from valve or blizzard with real acceleration) –  acidzombie24 Mar 20 '11 at 23:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.