Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Everytime I type some text, it is overwriting what I have typed. I assume that the mode is set to overwriting,

I want to insert the text not overwrite it, but I can't disable it because my insert key is mixed up with my delete key so everytime I enter insert to disable the overwrite mode, it just delete what I type.

So how to disable this?

I'm using centOS.. and it seems that my problem is only related to Netbeans because when I type here, it is set to insert mode.. but in Netbeans, it just overwrites the codes! help!

share|improve this question

2 Answers 2

I don't know about CENTos, but I know that there are 2 insert keys on your keyboard. The second one is on the keypad at the right. Disable numlock, then press 0. This should turn insert mode on or off.

Otherwise, google for programs called "key remappers". If this is some kind of linux, this link might have useful info: http://www.linuxscrew.com/2008/09/15/faq-how-to-disableremap-a-keyboard-key-in-linux/

share|improve this answer

Check the file /etc/sysconfig/keyboard and check the line KEYBOARD=xx. Make sure the xx is appropriate for your keyboard layout.

You can set up the language and keyboard using the commands system-config-language and system-config-keyboard.

If the standard keyboard layouts don't match your keyboard, you can make smaller changes (with more work on your part) by reading the output of man showkey, man loadkeys and man keymaps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.