Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I googled this problem thoroughly before posting here. I did everything in the books to set Firefox as my default. I went to default programs, and looked for it there -- it's not there. I went to the option menu and clicked check now -- nothing happens.

EDIT: I do have Firefox installed. It doesn't show up in the default programs window. And there is no option to browse and find and add a new default program. Hence my question.

EDIT2: Here is the screencap. You don't see any way to ADD a default program. You can only set one of the programs on the left as your default.

share|improve this question
    
The image in the second edit is broken. –  8088 Aug 31 '11 at 2:00
add comment

migrated from serverfault.com Mar 19 '11 at 8:17

This question came from our site for professional system and network administrators.

6 Answers

up vote 5 down vote accepted

Do you have Firefox installed?

Ok, now that that's out of the way... Try this after exiting Firefox completely:

firefox.exe -silent -setDefaultBrowser

That will set firefox as the default browser and you should be good to go.

share|improve this answer
1  
+1 for lolfactor. –  msanford Jul 3 '09 at 4:54
    
ha - i agree +1 –  Scott Ivey Jul 3 '09 at 5:02
    
yes, yes. That's not very helpful. –  picardo Jul 3 '09 at 5:27
    
This thread..and the comments...it's like 4chan has found a beachhead on serverfault.com. Ha. –  picardo Jul 3 '09 at 5:37
add comment

Maybe the tool I found on this page (Register Firefox Portable With Default Programs in Windows Vista) could be helpful.

I guess it should work for the regular Firefox version too.

share|improve this answer
    
Perfect! That worked. It's ridiculous to have to download another program to add a program to my default options, but i'm glad to have this resolved. –  picardo Jul 3 '09 at 19:34
    
Worked for me in Windows 7 (for portable version of firefox run from hdd). Thanks –  MadBoy Jul 1 '10 at 18:12
add comment

In Firefox: Tools > Options > Advanced > System Defaults > Check Now

Works fine for me. FF 3.5 in 7 RC1

share|improve this answer
    
Thanks. But that was the first thing I tried. :-( –  picardo Jul 3 '09 at 5:32
add comment

With the recent announcement from Microsoft of their upgrade strategy for the Windows 7 platform, it is highly unlikely that they are doing anything clandestine with regards to competitor browser vendors.

The European version of Windows 7 won't even ship with Internet Explorer.

Here are a few excerpts:

Microsoft said these upgrade options will not be available to Europeans. "We will not be able to offer an upgrade product within Europe," said John Curran, Windows business lead at Microsoft UK, adding that only the full version of the software will be available to Europeans.

In Europe, Microsoft will send buyers of new PCs a full version of the software rather than an upgrade version. The European edition will lack Internet Explorer.

The upgrade option was not available, Microsoft said, because it was trying to comply with European competition regulations. This means that IE is not onboard Windows 7 in Europe.

This bit really makes me laugh, just like the industry experts calling for Microsoft to start distributing 3rd party product updates through the Windows/Microsoft Update interface:

A Commission spokesman dismissed Microsoft's claim that it was taking the action to comply with European laws. [snip] The preferred remedy for Europe, he said, was to offer users a screen when they first switch on Windows 7 that gives them a choice between IE, Chrome, Firefox, Safari or Opera.

share|improve this answer
    
Except doing things like silently installing the .NET Framework as an add-on in Firefox through Windows update? ;) –  msanford Jul 3 '09 at 5:21
add comment

here is the solution directly from microsoft

If a program does not show up in the list, you can make the program a default by using Set Associations.

Click to open Default Programs.

Click Associate a file type or protocol with a program.

Click the file type or protocol that you want the program to act as the default for.

Click Change program.

Click the program that you want to use as the default for the file type you selected, or click the arrow next to Other Programs to show additional programs. (If you don't see Other Programs, or your program is not listed, click Browse to find the program you want to use, and then click Open. If no other programs are installed that are able to open the file type or protocol, your choices will be limited.)

Blockquote

share|improve this answer
add comment

I had a similar problem & found a solution at http://www.ghacks.net/2009/11/16/how-to-change-default-programs-in-windows/ I hope it helps you

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.