Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my Windows 7 Homegroup, between two Windows 7 Home Premium machines.

On one machine I get this:

Homegroup not available

The other machine in the Homegroup is perfectly happy and is able to see and browse this faulty machine as if there is nothing wrong. The Network and Sharing Center shows that I am joined to a Homegroup on my "Home" network and nothing is out of the ordinary.

I have tried leaving the Homegroup and rejoining/recreating it several times and that does nothing at all. Normal browsing to machine names and looking through folders seems to work, but it's a much more clunky way to get stuff compared to the convenience of the Homegroup facilities.

Starting the troubleshooter detects some problems with a "Peer Networking" (PNRpr or something like that) service not starting but fails to fix anything. Sure enough when I go to view the services via Control Panel -> Administrative Tools -> Services I see that both the "Peer Name Resolution Protocol" and "Peer Networking Grouping" services are stopped.

Attempting to start the "Peer Networking Grouping" gives an error that a dependency service will not start, the only service it is dependant on is the "Peer Name Resolution Protocol" so I try to start that and I get an error saying that the "service could not start due to error 0x80630801"

This has happened before and I have fixed it then by using System Restore and restoring the machine to a week before when I knew it had all worked. This time though I cannot remember when I last used the Homegroup from this machine and I've installed quite a bit so I don't want to go fumbling through restore points trying to find one that works...

Can anyone tell me if there is a way to reset things so that this machine is able to use the Homegroup again?

share|improve this question
    
Resetting things might not matter if there is an underlying issue as to why this isn't working. Can you ping the functioning system from the broken one (by both IP address and hostname)? –  MaQleod Mar 19 '11 at 21:51
    
I also looked up that error you got, take a look at this page, it might help: social.technet.microsoft.com/Forums/en-US/w7itpronetworking/… –  MaQleod Mar 19 '11 at 21:53
    
@MaQleod, Both machines are otherwise networking and communicating with each other and the internet fine, it is simply the Homegroup functionality that is broken. I've gone through the thread you linked and deleting the file idstore.sst under C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking and restarting the services fixed the problem and Homegroup now works again, though I don't know if it's a permanent fix or what broke it in the first place. It sounds like the file is getting corrupt somehow, no idea why... If you post that as the answer then I'll accept it. –  Mokubai Mar 19 '11 at 22:52
add comment

1 Answer

up vote 2 down vote accepted

I looked up that error you got, take a look at this page, it might help.

Deleting the idstore.sst file in C:\Windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking appears to be the resolution that has worked for most people in that thread.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.