Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Any time I click inside a text box, and saved form data pops up, available to click and select, I receive the following error:

Google Chrome: chrome.exe - Unable to Locate Component.
This application has failed to start because nspr4.dll was not found.  
Re-installing the application may fix this problem.

It also occurs any time I click on a drop down box. It takes 3 or 4 times to dismiss the error message, each time popping up again.

I have tried un/reinstalling Chrome without any effect.

I am on WinXP SP3, with Avast AV.

share|improve this question
    
I looked and I couldn't find a nspr4.dll file either in my Google Chrome installation or my Windows XP SP3 System32 folder. It might be coming from a broken plugin or extension. Run Mozilla Plugin Check (which works for Chrome) to see if you have an outdated plugin. If not, try browsing to about:plugins and chrome:extensions and disabling them all and see if the problem goes away. If so, turn them on one by one until you isolate which one is causing the problem. You can then remove it or see if there is an updated version. –  Patches Mar 20 '11 at 1:21

3 Answers 3

Possibly related to Roboform, if you have that installed. Try the advice given in item #12 in this thread on techsupportforum.com.

Earlier suggestions in the thread did not work for me.
But disabling the option described in #12 does seem to be working for me (so far).

Roboform Options->Browser Integration, untick "Attach Roboform to Firefox even if Adapter is not installed"

Good luck!

share|improve this answer

The AI RobotForm can cause all of these issues. Even it's disabled in Chrome, the error can still persist.

Go to the AI RobotForm web site and download the latest version which will solve the problem. If you don't want to upgrade, try to re-install the old version.

share|improve this answer

It’s not Chrome that needs to be reinstalled, and it’s not a system file. That file is related part of Netscape/Mozilla. (NSPR stands for NetScape Portable Runtime.)

Do you also have FireFox installed? Have you recently installed or uninstalled a plugin?

Open the chrome://plugins page and disable your third-party plugins and see if the error still occurs (try restarting the browser after disabling them). Then re-enable them one at a time (consider restarting the browser after each) to figure out exactly which plugin is causing the problem. Once you’ve figured that out, then you can simply reinstall that plugin.

Another (less ideal) option would be to simply search your hard drive (especially in the FireFox directory if you have that) for the file and copy it to the Chrome directory, but again, that’s not ideal, particularly since that file should not even be in the Chrome directory.

share|improve this answer
1  
NSPR is actually a foundation for programming that provides functionality that would normally be accessed by system calls or a C library to permit programs to be ported to different operating systems more easily. It has little to do with NPAPI plugins. In addition to Firefox and Chrome, there are many programs that have nothing to do with web browsing that use it. (In his case though, it's likely he has a plugin that assumes it's being used on Firefox and trys to use libnspr4, which Chrome does not ship. So copying it from Firefox might indeed help.) –  Patches Mar 20 '11 at 1:47
    
I’ve adjusted the definition accordingly. Since Chrome does not use the file itself, the plugin should be responsible for detecting whether it is present and install it if necessary, especially if it is meant to be cross-platform and not just FireFox (though chances are it is an older plugin from the Netscape days). –  Synetech Mar 20 '11 at 1:54
    
I've disabled all Chrome plugins, restarted, and the problem remains. I have no Chrome extensions installed. I copied the nspr4.dll file from Mozilla Firefox to the Chrome application folder, and I received a similar error regarding mozcrt19.dll, plc4.dll & msvcr80.dll. I copied these files, then I received a different error: –  Steve Mar 20 '11 at 7:34
    
Microsoft Visual C++ Runtime Library Program: C:\Documents and Settings\Steve\Local Set... R6034 An application has made an attempt to load the C runtime library incorrectly. Please contact the application's support team for more information. –  Steve Mar 20 '11 at 7:35
    
The above C++ error only occurred after I coped msvcr80.dll to the Chrome application folder. The first version of msvcr80.dll I copied was from: c:\program files\LAst.fm\Microsoft.VC80.CRT\ - version 8.00.50727.762 c:\program files\Dell V105\Diagnostics - version 8.00.50727.42 –  Steve Mar 20 '11 at 7:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.