Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have already disabled the Win-key hotkeys with NoWinKeys as well as the Win+Arrow keys in the DWM. However Win+P, the hotkey for the projector settings (which I don’t use anyway because I have a desktop with only one monitor, not a laptop) seems to be immune to that setting. Every other Win-key hotkey is disabled (including, to my chagrin, Win+Tab), but Win+P remains resolute to ruin my day by preventing me from mapping it to a command prompt. (To be accurate, Win+U is also adamantly reserved for the accessibility options, regardless of whether or not you enable or use them.)

Since I have used NoWinKeys, I suspected that it must not be getting hooked by Explorer, but rather some other component (a driver?) like the Mobility Center (which also hooks Win+X), however again, I am not using a laptop. (I do recall at one point in the past using some hack to enable the Mobility Center on a desktop, but I think that was in a previous installation because that key doesn’t exist now.)

Does anyone know how to disable Win+P or how to figure out where it is being hooked in order to stop it?

(Yes, there are two questions on SU that mention Win+P, but neither has a solution to this.)

share|improve this question
1  
Out of curiosity... why do you want to do this? Not saying it's an unreasonable question, just wondering. –  nhinkle Jul 26 '11 at 3:29
1  
(1) I hate seeing that stupid (and useless, unused) projector popup whenever I press Win+P. (2) Like I said in the question, I use Win+P as a hotkey for the command-prompt. I am sick and tired of having to hold Ctrl+Shift+P to open a prompt because it requires an extra key, and requires more hand-contortion, especially since I use the command-prompt a lot. (3) I don’t like Microsoft deciding what I need. I also don’t use the accessibility control panel (except for MouseKeys which already has its own hotkey), so I don’t like Win+U being forcibly taken. –  Synetech Jul 26 '11 at 6:22
1  
Adding to (1), unlike the Task Switch dialog, the stupid Projector dialog doesn’t go away when you let go of the hotkey, it stays on screen until you specifically dismiss it by reaching up to hit Escape, which is even more annoying. –  Synetech Sep 8 '11 at 1:07
1  
Just to say I completely agree with you, we should be able to do with the hot keys just what the heck we want to. I just wish we could do it with/ any additional programs. Upvoting everyone! –  Brave Newbie Dec 4 '11 at 23:47

1 Answer 1

up vote 3 down vote accepted

You can disable Win-P with a simple AutoHotkey script, that consists of four characters:

#p::
  1. # stands for windows key
  2. p is for - well - p
  3. The :: is for "hotkey"

If you want to run the command prompt with Win-P the code will look like this:

#InstallKeybdHook ; to make extra sure the keys are caught by AutoHotkey 
#p::run cmd.exe

I've tested both and they work for me under Windows 7 Ultimate. If you don't want to install AutoHotkey, download the zip, create the script in an editor and save it with the .ahk ending. If need be, it can be compiled into an .exe.

I have actually created a pretty nice post about disabling hotkeys with AutoHotkey.

Using AutoHotkey, you can customize and remap pretty much any key or hotkey on your keyboard.

But essentially I agree: any decent program should come with a built-in functionality to customize or disable hotkeys for certain functions.

share|improve this answer
    
I already did that a while back and it works for a while, but eventually stops working and Winx+P reverts to displaying the projection dialog. +1 because I’ve been using this method for several months, but would prefer a way to stop Windows from stealing the key for no reason (I have only one display on a desktop system). –  Synetech Dec 5 '11 at 0:40
    
Funny, I have never had a script stop working. Really strange. A clear case of Gremlins. Sorry, cannot provide you with a sure-fire way to stop Windows from stealing. I have adapted the script with the keyboard hook for AutoHotkey. Does this help? –  user 99572 is fine Dec 5 '11 at 22:20
    
I’m already using #p::Run %ComSpec% /k cd /d %desktop% and like I said it works fine most of the time but occasionally reverts. Either way, it does not help for other people who want to use the key combo for other purposes with other programs. :-( –  Synetech Dec 5 '11 at 22:37
    
I’m accepting AutoHotKey as the provisional answer because it is what I have been using since I first noticed the issue. Like I said, it is not ideal, and hopefully AHK can fix the issue where hotkeys stop working in Vista+, but at least it works. (Actually, I created a fancy CMD.ahk script that does this and more. ☺) –  Synetech Jun 11 '13 at 13:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.