Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My home machine is intermittently failing to send data (via ethernet) on my LAN. There is a 4 port wireless router, with 3 other devices that are working fine. I've tested two of them with ethernet (normally they use wifi), and that's fine too. Normally all IPs are assigned by DHCP in the 192.168.1.x range.

Symptoms I have seen:

  • Reports of IP address conflicts on other devices (bizarre in itself, because this setup has been stable for months)
  • XP reporting "limited connectivity" (ie, the same as when the network cable is completely disconnected)
  • The router showing "incomplete" as the ARP status for my machine.
  • After statically assigning an IP, getting "dynamic" as the ARP status, everything looking normal...but total inability to communicate with anything else on the network (or beyond).

And then, sometimes it's completely fine. (It fluctuates over a period of hours.)

In other words, various levels of connectivity between zero and perfect.

The only explanation I can think of is that my NIC (integrated into my 5 year old motherboard) is dying. Otherwise I would like to blame the router, but it seems to be behaving itself. I have tried using different ports.

Wondering if I have overlooked anything. Any other tests I can try? Suggestions?

share|improve this question

migrated from Mar 20 '11 at 12:55

This question came from our site for system and network administrators.

To add more weird symptoms, I just set the connection back to use DHCP again. The router reports that it assigned it XP continues to report no IP address for a minute or so. Then, suddenly a bubble pops up saying the network connection has been established...and ipconfig /all starts reporting that it has automatically been assigned! (That's the address I was previously assigning manually.) Bizarre. – Steve Bennett Mar 20 '11 at 12:45
Please read our FAQ, this problem is more appropriate for our sister site – Chopper3 Mar 20 '11 at 12:55
Thanks - the scope of serverfault wasn't quite what I thought. – Steve Bennett Mar 21 '11 at 1:11
up vote 1 down vote accepted

The advice given here worked:

Probably my TCP/IP stack was broken, and WinSockXPFix fixed it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .