Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Outlook 2010, I have only one profile. I have selected always use this profile in the profile settings as described in this question.

Nevertheless, each time that Google Calendar Sync starts a synchronization, Outlook pops up the select profile dialog.

This question was asked on the Google support forum, but there was no definitive answer. Browsing through the answer, there seem to be three workarounds:

  • open outlook and keep it open (hidden or visible)
  • use a Windows keyboard macro to press Enter automatically each time the popup appears.
  • install iTunes and MobileMe.

All these solutions are hacks which might work, but certainly can't be recommended to other people having the same problem.

The last workaround obviously changes a setting somewhere that solves the problem. I was wondering if anyone knows which setting this might be, and how to change it manually, and consequently beat the Google forum providing the right answer.

share|improve this question
    
I've been looking for a solution for this for what seems like years. –  antony.trupe Apr 20 '11 at 14:12
add comment

4 Answers

This worked for me - it's not a fix but a workaround.

  1. Install AutoIt

  2. Paste the text below into a Notepad window and save it as outlookProfile.au3 (change the Save As Type dropdown to All Files)

    While 1  
    
        WinWait("Choose Profile")
        if (WinActivate("Choose Profile")) Then
          ControlClick("Choose Profile", "OK", "Button2")
        endif
    
    WEnd
    
  3. Double click the file.

  4. You may want to add a shortcut to your startup so that you don't have to run it each reboot. To make it run on startup you want to copy a shortcut of the file to the Startup folder in the Start Menu:

    %ALLUSERSPROFILE%\Start Menu\Programs\Startup
    
share|improve this answer
1  
Thanks for your answer, which is one of the workarounds mentioned in the question. I asked explicitly for the solution for the problem, not for a workaround, so I won't mark it as the accepted answer. –  Jan Willem B Apr 11 '11 at 11:28
add comment

In Outlook 2010 File -> Options -> Add-ins Manage: COM Add-Ins pull down at bottom, Click: Go Under Add-Ins available: Google Calendar Sync was unchecked. tick it and click OK.

share|improve this answer
    
That doesn't make any difference. It probably works at your computer because Outlook is still active in the background. –  Jan Willem B Feb 23 '12 at 8:24
    
concerning answer: In Outlook 2010 File -> Options -> Add-ins Manage: COM Add-Ins pull down at bottom, Click: Go Under Add-Ins available: Google Calendar Sync was unchecked. tick it and click OK. Confirm that, after having stopped Outlook from the background using Task Manager, popup came back –  user136124 May 24 '12 at 21:58
add comment

I found a fix that worked for me. I am running Windows 7 and Office 2010.

Based on the documentation of LoadBehavior, I experimented until I found a setting that worked.

In short go to:

HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\Google.GoogleCalendarSync

Change the LoadBehavior to 0 (mine was set to 8).
source

share|improve this answer
1  
Thanks for the answer. Theoretically I can't see a way that this should work. And practically neither, as I tried it and it does not help. Btw, the path to the setting is not correct. –  Jan Willem B May 24 '12 at 14:10
add comment

Turn Off the reminders - it bothers the sync process. Here is how:

Click the File menu –> Options link. Navigate to Advanced tab. In the Advanced tab, go to the Reminders section. You can turn off the reminder alerts in Outlook 2010 by unchecking the check box with label as Show reminders.

share|improve this answer
1  
Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Bob Jun 12 '12 at 7:14
add comment

protected by Community Jul 4 '12 at 18:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.