Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After reinstalling Windows 7 (64-bit), it has stopped recognizing my iPhone. I can see it in iTunes but not in Windows Explorer, so I can't get the photos off. I'm having this problem on three different machines and two different iPhones (my wife's and mine). It's maddening.

I've had every version of iPhone since it first came out and I've never had this problem before.

I've uninstalled and reinstalled iTunes (currently at 10.2.1.1). I've updated iOS on the phone (currently at 4.3).

In the device manager, this is what I see:

device manager screenshot

Here's the properties screen for the unrecognized iPhone:

properties screenshot for the unrecognized iPhone device

And here's what I get after going through the "update driver" process:

enter image description here

Any ideas? At the end of my rope here...

share|improve this question
    
You upgraded three different machines to Win7, and none of them can see either of your iPhones? –  goblinbox Mar 20 '11 at 19:50
    
@goblinbox - That's correct, except they were running Win7 before (& playing nicely with the iPhones) but all were recently reinstalled from scratch (scorched-earth approach to virus removal). –  Herb Caudill Mar 20 '11 at 20:25
    
Probably a dumb question, but have you run Windows Update to be sure these fresh installs have all the patches and hotfixes? –  goblinbox Mar 20 '11 at 20:47
    
@goblinbox: Yes, Windows Update is up to date. –  Herb Caudill Mar 20 '11 at 23:34
1  
Have you tried using a new iPhone cable or a different USB port on the computer? I wonder if it's not recognizing it because of a short in the cable. As well, should you need to, you can make an appointment at the nearest Genius bar and see if they can figure out what's wrong - it could be something wrong with the phone's dock connector. –  Jared Harley Mar 21 '11 at 14:29

5 Answers 5

Anecdotally, I have seen (in the Apple support forums) that a similar issue has been solved by installing an older version of iTunes, specifically, downgrading from 10.2.1 to 10.0.

share|improve this answer
    
Thanks for the suggestion. I tried uninstalling and downgrading iTunes, first to 10.1 and then 10.0; still have the same problem, and now iTunes is unhappy about the library from the more recent version, so I think I'll go back to 10.2. –  Herb Caudill Mar 20 '11 at 23:37
    
Ugh. Well, it was the best information I could find. :-( –  goblinbox Mar 21 '11 at 0:07

Workaround (FWIW): This isn't technically an answer to my question, but it's solved my actual problem, which is that I need get photos and videos off the iPhone. I've installed the CameraSync app ($1.99), which connects to my Dropbox account to automatically and continuously uploads my camera roll. It also connects to iDisk, FTP, S3, Flickr, and Box.net.

share|improve this answer
    
The only problem with this solution (and the reason why I'm offering a bounty) is that CameraSync doesn't delete photos from the iPhone. If I can't open the iPhone's photo folder in Windows, the only way to delete photos on the phone is one by one, which takes forever. –  Herb Caudill Jul 15 '11 at 12:13

Apple has a page for troubleshooting your problem.

share|improve this answer
    
No, please re-read the question. iTunes sees the iPhone. Windows doesn't. –  Herb Caudill Jul 15 '11 at 12:11
    
If you look at the top of the link where it says Symptoms, one of them is "An exclamation point, question mark, plug symbol, or "X" appears next to the device's entry in Device Manager.". This fits your description. –  Sharken Jul 15 '11 at 12:28

I know this may sound crazy. But try doing a system restore, and then see if it shows up. I had a phone driver that I was able to fix this way (it was for Sprint? so not an iPhone). I have no idea why or what was going on but the system restore allowed the phone to show up.

I am curious to see if this is the case again so let me know if you give it a whirl.

share|improve this answer

http://support.apple.com/kb/ts1538

http://docs.info.apple.com/article.html?artnum=61711

"It will take about 2-3 minutes than an yellow exclamation point will come up..."

1) push power button camera button to power on phone. Keep holding till menu comes up. 2) push volume down. It will take about 2-3 minutes than an yellow exclamation point will come up. (you`ll know when it happens). 3) Once on that screen, tap the bottom right hand corner of the touch screen. A menu will appear and you can select restore to factory settings. Everything is touch at that point. If you dont see the menu pop up just tap a few more times on the bottom right hand area of the screen. It took me a little bit to find the right spot. It will work I promise, I just searched for hours trying to find the answer. Good luck and feel free to PM me with any questions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.