Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is it possible to disable or lock the zoom feature in Notepad++ ? I'm doing a lot of copying and pasting, and the zoom level keeps changing on me. It's driving me nuts!

share|improve this question
    
Should be migrated to Superuser –  rightfold Aug 17 '09 at 21:09
add comment

migrated from stackoverflow.com Aug 19 '09 at 20:59

This question came from our site for professional and enthusiast programmers.

5 Answers

Question is quite old but if someone still wants to disable mouse zooming, I wrote a small plugin for Notepad++ which does it: https://sourceforge.net/p/notepad-plus/discussion/482781/thread/3b39ebd3/

share|improve this answer
add comment

I have a logitech mouse and love it. It has a mousewheel that doesn't 'click' as you scroll, but operates more like a flywheel... So, when I scroll somewhere and then start using the keyboard (eg, Ctrl+C), suddenly I've zoomed. Most annoying ;)

Changing shortcuts isn't the issue here. It's the way we use an editor and it's not really the mouse's problem.

PS: I can do a 'hard' center click on my mouse and it changes it from 'flywheel mode' to 'click mode' and back. It is the only workaround I have...and notepad++ is the only program I need to do this with.

share|improve this answer
add comment
up vote 0 down vote accepted

The zooming is happening (I think) because I have a cheap M$ mouse, and the scroll wheel sometimes doesn't roll all the way to the next tick when I stop scrolling. Then, later, when I'm using Ctrl+C/Ctrl+V top copy and paste the wheel snaps into place, thus causing what appears to be a spontaneous zoom. Unfortunately, becuase this problem is occuring on my PC at work, I don't have the option of replacing the mouse, which would be my normal solution. So, what I would like to do, if possible, is disable or lock the zoom feature on Notepad++. Thanks.

share|improve this answer
    
I ended up getting a better mouse. –  Jim Fell Aug 11 '10 at 20:07
add comment

Seriously I cannot imagine a scenario where you're accidentally zooming. The hot keys involve Control-Mousewheel, or Control-Keypad-plus-or-minus. (If you'll excuse the description). These aren't near or similar to Control-C and Control-V. So you must be holding the control key while meaning to scroll in the document.

Anyway, it's been a while since I used it, but I'm told you can edit the shortcuts in the settings > shortcut mapper. Since the zoom shortcuts must be causing you trouble, remap or disable them.

share|improve this answer
    
No, you can edit NPP shortcuts now, going to Settings > Shortcut mapper. –  Igoru Aug 20 '09 at 2:38
    
@Igoru thanks, I've edited the answer to reflect this. –  dlamblin Aug 20 '09 at 8:39
2  
Some mouse wheels are a bit finicky and can scroll when you aren't touching the wheel (eg. you stopped turning just before the next skip, and a minute later it is jostled passed it). If you're hold control at the time, you zoom. This happens to me all the time. –  Strilanc Jan 13 '10 at 18:02
    
@Strilanc I never encountered this but it sounds aggravating. Consider buying another mouse. I'm happy with my logitech.com/index.cfm/428/3287&hub=1&cl=us,en –  dlamblin Jan 16 '10 at 22:19
1  
dlamblin, it happens when you Ctrl+C and then start scrolling a split second before you let go of Ctrl. Happens to me from time to time -- it just depends on the user. –  nbolton Jun 9 '12 at 23:52
show 2 more comments

I don't have that issue. The only way it zooms is if you use CTRL-MouseWheel, or by CTRL-KP+ or CTRL-KP-. Most likely, you are trying to scroll the document when you still have CTRL held down (or active via StickyKeys.)

Best recommendation is to use CTRL-KP/ to reset the zoom.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.