Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After a series of updates, my chrome browser will not display flash content properly anymore.

For example, if I go to speedtest.net I can see the speedtest applet but it's flickering funny colours and not loading correctly.

Other flash websites don't load at all.

Originally, I installed flash using the process described here.

http://maketecheasier.com/enable-flash-support-in-google-chrome-in-ubuntu/2009/08/19

I tried reinstalling everything but the result is the same.

Any ideas?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Solved it myself. One thing I didn't mention is that I'm on a 64bit version of linux. I think this is the issue.

For Chromium in Ubuntu or Kubuntu linux, uninstall the package flashplugin-installer i.e. in a terminal window

sudo apt-get remove flashplugin-installer sudo apt-get autoremove

Then run

sudo mkdir /opt/google/chrome/plugins

Then go here: http://labs.adobe.com/technologies/flashplayer10/square/

Download the 64bit version of adobe flash player "square".

Copy the enclosed libflashplayer.so to /opt/google/chrome/plugins

Restart chrome and it should be all go from there.

share|improve this answer

Purge (completely remove) flashplugin-nonfree and then simply reinstall the same.

This downloads a new version of Flash player completely with updates etc automatically. No reboot needed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.