Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to print a PDF file in Opera, it prints each page as a blank page. When I try it in Firefox it works just fine. Does anyone know how I might go about fixing this?


  • Windows 7 Pro 32-bit
  • Opera 11.01
  • Using Adobe Reader 10.0 plugin
share|improve this question
If you try using a different PDF app to print, such as PDF creator, do you see the same problem? (just trying to narrow down if it is opera, or the adobe plugin that is causing the problem). – MaQleod Mar 21 '11 at 7:59
The same plugin works fine in Firefox, so I think it must be Opera. – DanielGibbs Mar 21 '11 at 8:16
not necessarily, there could be a bug with that plugin when used with opera, or there could be something about the way opera passes information while printing that causes printing to PDF to fail, regardless of the method. – MaQleod Mar 21 '11 at 8:24
Ok, but I couldn't find any other PDF plug-ins for Opera for me to test. – DanielGibbs Mar 21 '11 at 10:02
up vote 1 down vote accepted

Opera's printing support is super buggy and always has been. But, it gets worse with each release. Regressions are almost never fixed.

With that said, you're better off just right-clicking on the page and choosing a different browser under the "Open with" menu and printing in that. (IE prints way better than any other browser in almost all cases.)

However, you can tweak Opera to work a little bit better.

Goto "Menu -> Print -> Print Options"

  • Uncheck "Print page background".
  • Uncheck "Print headers and footers".
  • Set "Scale print to" to 100%.
  • Uncheck "Fit to paper width".
  • Set margins to 1.27cm all around.

Then, try printing. But, make sure you don't print from print preview as that can cause even more bugs.

Note though that even though setting "Scale print to" to 100% makes Opera print things at the proper size, it may cause blank pages. You can trying manually typing in 94% for example to see if you can find a percentage that gets rid of the blank pages but still looks nice.

However, in your case, it's the Adobe Reader plug-in itself that's embedded in a page in Opera. The plug-in is what does the printing of the pdf. If the plug-in isn't printing correctly while loaded in Opera, then it's probably a bug in Opera. But, note that the Adobe Reader plug-in is known for being buggy itself.

To avoid the plug-in, just save the pdf file to your hard drive and open it directly in Adobe Reader. You can configure this in Opera too by going to "Ctrl + F12 -> Advanced -> Downloads -> application/pdf -> edit" and setting it to "open with default application". That will cause pdf files to open directly in the Adobe Reader app, which will totally avoid the problem.

You can also try installing Foxit Reader and its browser plug-in. Opera will automatically recognize that plug-in. But, you should goto opera:plugins in the address field and disable the adobe one. Then, edit the application/pdf file type and set the drop-down under "use plug-in" to use the Foxit plugin. This plug-in works fine in Opera.

share|improve this answer
Thanks! I've changed the settings you mentioned, and PDFs appear to print fine now. But any other page, for example this one, it just prints everything as a wall of text, with no formatting at all, not even new lines! – DanielGibbs May 7 '11 at 21:37
This page prints out fine for me with those settings. It sounds like you tried to select everything on the page and print the selection. In that case, you'd get what you described as Opera only supports printing text in a selection and it also has some bugs with newlines when doing so. In other words, if you print the full page, it should work. – Shadow2531 May 9 '11 at 1:17
Ohhhhh, yeah that would be it, usually I just select the bit of the page I want and print selection. Thanks. – DanielGibbs May 9 '11 at 18:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.