Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a Linksys router WRT610N v2 and I installed DD-WRT build 14896 preSP2 on it.

I bought a Linksys Dual Bank Wireless N adapter for my laptop.

I have no idea how to configure the router for dual channel.

It seems that I have two different wireless devices that I can give them different SSID names and different wireless encryption settings.

I tried giving them both the same name, same encryption and same password, but when I try to connect I see that I'm on 140MHz speed and not 300, so I'm probably missing something.

share|improve this question
1  
Is there any reason you installed DD-WRT rather than the manufacturer firmware from linksysbycisco.com/UK/en/support/WRT610N/download ? I'm assuming you needed extra features, but in general the best device support/speeds are in the manufacturer builds and things like DD-WRT only support the devices far enough to get the device to "just" work. Do you get the full 300Mbps reported with the factory default firmware installed? –  Mokubai Mar 21 '11 at 13:25
    
in general you are correct. it's better to use the manufacturer's version. i upgraded the firmware to the original one. –  ufk Mar 22 '11 at 8:44

2 Answers 2

up vote 1 down vote accepted

Your router is dual BAND router. That means that it does indeed have TWO radios. One on 2.4 GHz and one on 5 GHz. So it is perfectly normal that you have two different wireless devices.

What you are looking for is called 40 MHz mode. Here's an article describing how to set it up.

If you can't see 40 MHz mode anywhere, make sure your router is set in one of the modes which include N. Then you should see 40 MHz option. I can't tell you exact steps because I don't have DD-WRT router right now and dummy web interface doesn't have N support yet.

share|improve this answer
    
thank you!! your article made it all clear ;) i took @Mokubai advice and installed the original firmware. testing it now –  ufk Mar 22 '11 at 0:35
    
everything works. thanks –  ufk Mar 22 '11 at 8:45

First, the Cisco-Linksys firmware is totally useless. It is so slow that it forgets what it is doing prior to loading the next page, so router settings get lost most of the time. That's why I switched to DD-WRT, which works MUCH FASTER and MUCH BETTER.

Setting up both the 5 GHz and 2.4 GHz radios is easy with DD-WRT. However, you must ensure that each radio is radically different from the other. Otherwise, the router confuses them.

  1. Avoid TKIP encryption for both

  2. Use AES encryption on the 5 GHz (N band)

  3. Use WEP encryption on the 2.4 GHz band

  4. Make sure your SSIDs are VERY different (e.g., Aardvark, Puma101).

  5. Set Wireless settings for auto everywhere that auto is a selection.

I'm not at home so I can't look at my router settings and I can't remember any others right now. But if you keep the radios radically distinct, you should be OK.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.