Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want the power button on my Windows 7 desktop to put the system to sleep. I can instruct Windows 7 to do this via the Control Panel, and this works, but every time I re-boot, the setting reverts from "sleep" to "shut-down". This can cause serious problems if I accidentally shut the system down when I wanted it to sleep.

How do I get Windows 7 to honor the setting I'm making in the Control Panel?

share|improve this question
This isn't normal behavior. Can you provide a little more detail as to what software you've got installed, whether you're on a domain environment, are you running as an admin, etc? – Shinrai Mar 21 '11 at 14:09
I am the sole user and run with Admin privileges at home; not a domain environment. I have LOTS of software installed: I don't know where to begin. – jon bondy Mar 21 '11 at 15:05
Anything you can think of that might alter power settings? There's gotta be something doing it. :/ Try changing the setting in Safe Mode? – Shinrai Mar 21 '11 at 15:20
Would there be an "Event" associated with such a change? Would looking in the system event logs be helpful? – jon bondy Mar 21 '11 at 16:08

This isn't typical and your setting changes should change. Are any of your other setting changes not saving? If it's a new problem, you might want to try doing a system restore and seeing if your changes are holding following that. You could also try playing around with the power management settings as well:

share|improve this answer

Check your BIOS power management settings, they can conflict with the Windows settings.

share|improve this answer

To get to the absolute bottom of this problem might take a bit of investigative work...

  1. Try changing the setting to how you want it, then dumping the whole registry to a .reg file.
  2. Reboot
  3. Dump the .reg file again
  4. Compare the two reg files (WinMerge)
  5. Set a program like Process Monitor to run at start up and see if you can find what is changing the key.
share|improve this answer

This worked for me Right click on the Start menu go to properties there in the "start menu" tab you will see a Power button option. There change it to Sleep After the recent Windows Update for some reason this setting here overrides all the power management setting in control panel for "power button" and "power Button and lid" options inside the Power profile

Mine was set to Hibernate. Now it works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.