Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Service Pack 1 for Windows Server 2008. Since that time, network performance has been awful. Both Windows 7 and Mac Snow Leopard clients have seen miserable speeds when trying to read or write to the server.

This is the exact update:

Windows Server 2008 R2 Service Pack 1 x64 Edition (KB976932)

It's a very simple file server setup. No Domain or Active Directory. Essentially just shared folders. It's Windows Web Server that I'm running.

Are there any settings I can tweak? Should I roll back the update (doesn't seem wise)?

Update:

I've turned off the Power Management for the Network Adapter. That may help. If it doesn't have to be powered on at the start of a request, it should speed things up. Or so I would assume.

share|improve this question
2  
So you've tried nothing, and you're all out of ideas? –  Ƭᴇcʜιᴇ007 Mar 21 '11 at 16:17
    
Thanks for the constructive help. –  Axeva Mar 21 '11 at 21:32

3 Answers 3

Make sure that TCP Offload is enabled. It's under the device properties for your network card. If you want to do it in the registry, MS has a guide here

share|improve this answer
    
There are a number of "Offload" settings --IP Checksum Offload is set to RX & TX Enabled. Large Send Offload V1 (IPv4), Large Send Offload V2 (IPv4) and Large Send Offload V2 (IPv6) are all Enabled. Same for the TCP and UDP Checksum Offloads. Does that cover it? –  Axeva Mar 21 '11 at 21:31
    
@Axeva: I think he means the TCP Offload Engine (TOE), which you usually find on discrete NICs. I don't think I've seen it on onboard network controllers. I doubt that this is the problem though. I have not had any problems with SP1 myself, apart from the problem with VMware Workstation memory allocation on Win7. –  paradroid Mar 21 '11 at 22:46

If you haven't already, try manually setting your transfer speed and duplex in the network card settings. Some devices don't always auto-negotiate these settings properly.

share|improve this answer

I'm assuming you've updated the NIC driver? At least start by reinstalling it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.