Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm accessing Windows via the RDC client for OSX.

Occasionally, the caps-lock willget out of synch between the two environments.

When this happens when I am using a Windows VM in VMWare Fusion, I can get the two in synch by using VMWare's send keys functionality.

Is there a way to correct this?

share|improve this question
add comment

3 Answers

Not usually, no. Given the way Caps Lock, numlock, etc maintain state, and the lack of ability for operating systems to allow programmers to CHECK that state and act accordingly, there's no way to keep them synced when outside influences (even the keyboard itself) are changing them. For CoRD we were always going to add a menu item that would allow you to force-send caps lock, numlock, etc so you could force things back in sync, but it continually got tabled and none of us ever made it back to adding that in.

It gets more complicated when you think about a machine with multiple keyboards plugged in. Turning caps lock on for one keyboard doesn't enable it for the others. So who's authoritative? This is one of those things that makes me hate working on RDP clients...

share|improve this answer
    
At least having the send-key option would be useful. In most cases, the multiple-keyboard issue won't exist. Moreover, the operator isn't forced to use the option in the case of a conflict. –  Craig Mar 22 '11 at 14:09
    
Thanks for the alert--it didn't realize that there was an alternative to M$ RDC. –  Craig Mar 22 '11 at 14:16
    
ever see a macbook user plug his laptop into a cinema display with a USB or bluetooth keyboard attached/paired? its a bigger usecase than most people think. –  peelman Mar 28 '11 at 4:29
add comment
up vote 1 down vote accepted

In OSX, the Keyboard Viewer application can be used to toggle the caps-lock key. It appears that Windows' On-Screen Keyboard application can be used the same way.

share|improve this answer
add comment

A really quick fix that also works for vmware player and ubuntu is to press ctrl-alt-del and then press caps lock (or num lock) then press escape and voila!

Actually I have just realised I completely misread the question so hopefully it is not completely irrelevant!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.