Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have created this custom command in WinSCP with options as described:

description: &Find
command: find . -name "!?Search for files:?!"
remote command: enabled
show results in terminal: enabled

Problems:

  1. When I right-click any of the remote directories, none of the remote commands are enabled (greyed out). Only local commands (e.g., print) is enabled. Why is that?

  2. When I add a new remote custom command, why is "apply to directories and execute recursively" disabled?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Got the answer to the 1st one. You gotta SFTP it and not FTP.

But the second problem is still there. When I add a remote custom command, "apply to directories" and "execute recursively" are greyed out. Don't know why.

update: got the answer for second one too. it seems winscp is smart enough to determine which commands require those special options. for ex., when i typed tar those options were enabled but such was not the case for ps command.

share|improve this answer

WinSCP Remote custom commands (as a kind of remote commands) work with SCP only (and with SFTP by fallback to SCP):
http://winscp.net/eng/docs/remote_command

Apply to directories: You need to have some file-related pattern in your command, such as !.

Execute recursively: The same as Apply to directories, except that you cannot use !& or !^!.

Both documented here (just click Help button on the dialog):
http://winscp.net/eng/docs/ui_customcommand

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.