Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a standard Apple Keyboard and an HP mouse. Both are USB. I start the server on the Mac, and then the client. The mouse works correctly on the windows machine, but when I try to type, nothing appears.

Here's my config:

section: screens
section: links
        left = windows
        right = us147137.local

I gave the windows box a screen name of windows for some reason, but that shouldn't cause the problem anyway, right?

You think it's just because of the Apple keyboard?


EDIT: Downgrade to the version below latest and it works!

share|improve this question
What version of Synergy are you using? I used a self-compiled version of the Mac server for 2 years with one to two Windows clients without issue. Used an Apple Alu keyboard the entire time. So its not the Apple keyboard. – peelman Mar 22 '11 at 14:54
Latest version for both client/server. – dmackerman Mar 22 '11 at 15:03
@dmackerman it would help, if you provide the version info of the patch you got working. – Kaushik Gopal Aug 19 '11 at 18:30
up vote 4 down vote accepted

I had this exact same problem, only with a Linux client and my OSX server. I rolled back to the synergy version 1.3.6 and had to run the server as root. However, I never got copy and paste to work this way.

You should also contribute to this bug report:

share|improve this answer

I think this is issue 47

share|improve this answer
Possibly. How do I install these patches? – dmackerman Mar 22 '11 at 18:09
One of the solutions noted there is to use SynergyKM on MacOS - this worked fine for me! – Stiefel Sep 2 '11 at 13:35

I had the same problem of Mac as server and Linux as client. Mouse worked and keyboard did not. After I "sudo synergys" to start the server as root, keyboard starts to work.

share|improve this answer

You must log in to answer this question.

protected by nhinkle Jun 1 '11 at 22:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .