Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Firefox 4 this morning excited to checkout some of the new HTML 5 features that have been implemented and found that all text was displayed in a bold font. Here is the comparison with what Firefox 4 is displaying on my machine and Chrome.

It is getting really annoying. So far I've...

  • Emptied the cache/history/etc.
  • Re-installed the various core fonts (Arial, Courier, Times New Roman, etc.)
  • Checked the font defaults in FF4.

The interesting part to me is that I had FF3.6x on this machine with no problems whatsoever and now this. Any ideas?

System Description

  • Windows 7 (x64)

Update

I just found out that this is happening in IE9 (final) as well. Must be something with the system fonts. Like I said before, this wasn't happening pre-FF4.

share|improve this question
    
Just include a link to the image, we can turn it into an image for you. Can you tell us what Operating System you use? As hardware accelerated graphics are used the fonts can depend on Operating System specific settings. –  Tom Wijsman Mar 22 '11 at 20:44
    
Have you tried re-booting your machine? –  Mick Mar 22 '11 at 21:59
    
@Mick LOL. Thanks for that one. –  Mateo Mar 22 '11 at 23:01
    
Did that solve it? @Mick: You might consider to place it as an answer so that Mateo can upvote and accept it. –  Tom Wijsman Mar 22 '11 at 23:06
1  
@Mateo; You'd be surprised, I've seen people really go the extra mile before rebooting. One person actually called me to ask if I had a spare install disc before rebooting(!) –  Phoshi Mar 23 '11 at 10:58
show 3 more comments

5 Answers 5

up vote 5 down vote accepted

Boy oh boy. So the answer lies in reinstalling Arial.ttf. Apparently when I installed the fonts from corefonts.sf.net in an attempt to fix the issue it didn't actually install the font but placed it in the %windir%\fonts directory. It wasn't until I accessed the font and then clicked "Install" at the top of the preview windows that it was installed. Shouldn't have trusted that executable installer. Now both IE9 and FF4 are displaying correctly.

share|improve this answer
add comment

I solved this problem by reinstalling some of the base fonts that come with Windows. I found this solution on the Windows Seven forums:

It sounds like you have somehow removed some core Windows fonts. ie uninstalling an app etc. Tahoma normal is now being shown as Tahoma Bold, Arial normal is now arial italic etc. Go to Control Panel\All Control Panel Items\Fonts and see if those fonts are still there.

If not:

unzip and copy the attached fonts to the C:\Windows\Fonts directory to see if restores everything back to normal.

Attachment: Fonts.zip

The attachment link is a .zip of all of these fonts. Double click each one to open and install.

Hope it helps.

share|improve this answer
add comment

If you are using Windows, this might be due to incorrect ClearType settings.

How to enable/disable clear type and change its settings.

enter image description here

share|improve this answer
2  
Cleartype is all good. –  Mateo Mar 22 '11 at 23:04
add comment

The thing that worked for me on Windows 7 was reinstalling Arial. Take it from here

Close Firefox, install it and you should be all set. No restart required or anything. Enjoy!

share|improve this answer
add comment

I had this problem as well. One solution is to turn off Hardware Acceleration in Options > Advanced.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.