Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've disabled "tabs on top" in Firefox 4, but it seems that double-clicking an empty area in the tab bar still behaves as if it was the title bar, so the effect is toggling window maximization.

I grew used to the Firefox 3.x behavior, which is to open a new tab when double-clicking an empty area in the tab bar; however, I could not find any way to restore that option in the Firefox options or even in about:config. Is it at all possible, and if it is, how?

EDIT turns out it's a known bug with Firefox 4 on windows.

share|improve this question
    
I never even knew FF3 did this, huh. –  Shinrai Mar 22 '11 at 22:55
    
Meanwhile, I'm just re-learning to middle-clicking the empty area - instead of double-clicking - to open a new tab. –  Oak Mar 30 '11 at 8:19

5 Answers 5

up vote 3 down vote accepted

This option is available with the Tab Mix Plus extension.

In the Tab Mix Plus options:

  1. Select the Mouse Menu
  2. Choose the Mouse Clicking tab
  3. Choose the Double-click tab
  4. For the "on the tabbar:" setting choose "Open a new tab"
  5. Click the checkbox: "Prevent double click on Tab-bar from changing window size."

Double click on the tabbar to create a new tab in Firefox

EDIT: Now there's an option in the mentioned dialog box, "Prevent double click on Tab-bar from changing window size." Setting that option, as well as the ones suggested above, fixes the problem.

UPDATE: Thanks for the tip - the updated dialog box is now included.

share|improve this answer
1  
Setting this option does not solve the issue for me - double-clicking still behaves as if on the title bar. I re-checked and restarted but it still doesn't behave as this Tab Mix Plus option suggests it should. –  Oak Mar 23 '11 at 9:04
    
That's odd, because I disabled Tab Mix Plus and Firefox 4 behaved as you described. Then I enabled it and it worked again - for me. I find it strange that the extension would work differently for different people. Do you have any other tab extensions installed? –  jmohr Mar 23 '11 at 14:10
    
No other tab extension is installed, and I've tried disabling and then enabling. Maybe there's some external factor affecting this. –  Oak Mar 23 '11 at 15:08
    
The option now exists in Tab Mix Plus to "Prevent double click on Tab-bar from changing window size." The dialog box image was updated to show current options and a 5th step was added to the instructions. –  jmohr Apr 30 '12 at 17:00

You can get this to work by turning the menu bar on. Go to the firefox tab, then options, then click menu bar. It gives a more classic look and will allow you to double click the tab bar to open new tabs.

share|improve this answer

middle-click (mouse wheel click) on the empty tab bar area

share|improve this answer
    
Indeed, I'm now re-learning to use middle-click instead. –  Oak Apr 6 '11 at 16:10

workaround: add this to userChrome.css

#navigator-toolbox:not([tabsontop="true"]) > #TabsToolbar {
  -moz-binding: url("chrome://global/content/bindings/toolbar.xml#toolbar")
!important;
}

you can drop :not([tabsontop="true"]) if you like it work as before also when tabs are on top.

Found @ https://bugzilla.mozilla.org/show_bug.cgi?id=575248#c27

share|improve this answer
    
Could you explain where can I find this file? –  Oak Mar 23 '11 at 11:33
    
userChrome.css goes into ~/.mozilla/firefox/$RANDOM_STUFF.default/chrome under linux I guess somewhere similar like this under windows. Create folder and/or file if they don't exist. Works like a charm! –  Sebastian Blask Jan 11 at 13:49

Setting the option in Tab Mix Plus works only if the menu bar is enabled. When the menu bar is not shown (default setting in FF4 with the new Firefox button), the described behavior occurs.

share|improve this answer

protected by random Jul 17 '11 at 14:01

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.