Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i have had this problem before with other OS's. I could usually solve it by just rebooting from in the virt machine. But everytime i reboot or start a FreeBSD 32bit desktop it wants to reinstall itself.
The first thing that seems to kickoff is: /boots/loader/default.conf
Should i change something in this?
edit: after /BOOT/LOADER that is

share|improve this question
    
freeBSD doesnt have tab-autocomplete? crap, is there some way to enable this? – fightermagethief Mar 23 '11 at 6:50
2  
Have you left the "disk" (usually an ISO) in the virtual CD drive? If the VM is set to boot from the CD first, this could be your problem (although I don't know enough about FreeBSD to be sure). – MBraedley Mar 23 '11 at 11:24
    
@mbraedley: yeah, stupid of me, the boot order was set to cdrom first and i still had the iso in storage – fightermagethief Mar 23 '11 at 21:51
up vote 1 down vote accepted

The only way it could try to reinstall itself is if:

  1. It is still booting off the CDROM image
  2. There is no /sbin/init but there is a /sbin/systeminstall

It is most likely option 1. Try removing the ISO image from the CDROM drive configuration.

And as for tab completion, that's down to the shell.

You can either use tcsh as your shell (chsh -s tcsh) or install bash and use that:

As root:

# pkg_add -r bash

As your user:

$ chsh -s bash
share|improve this answer
    
@:matt: yeah #1 was my problem, thanks for the shell info also – fightermagethief Mar 23 '11 at 21:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .