Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My FireFox is looking really really ugly since upgrading to 4.0 (definitely not how it's supposed to be looking), see screenshot below.

I had FF 4 RC installed earlier (which looked exactly the same, but I thought it was because it is a release candidate).

Un- and reinstalling firefox did not do the trick, I also tried disabling all add-ons. There is not other theme than the default (4.0) theme installed.

I know that deleting all Firefox stuff from "Documents and Settings" would probably help, but I would rather keep my firefox configuration/preferences etc, so if anyone can give me a clue what I can do about it, I would be very happy.

share|improve this question
    
@Daniel Beck: Just out of interest: you have removed the hello/thanks/goodbye parts of my question. Are things like these deprecated here? –  Peter P Mar 23 '11 at 9:15
    
@Daniel Beck: thanks for embedding the image :) –  Peter P Mar 23 '11 at 9:15
1  
What does it do when you create a new profile? (Launch firefox.exe -ProfileManager) Does it restore the UI for the new one? –  M'vy Mar 23 '11 at 9:15
    
@Peter Greetings and thanks, as well as signatures are unnecessary and detract from actual content. On our "meta" site we discuss topics related to SU, here's a response from a moderator on that topic. –  Daniel Beck Mar 23 '11 at 9:48
    
@M'vy Doesn't help, unfortunately, the UI looks exactly the same for the new profile. –  Peter P Mar 23 '11 at 11:17

2 Answers 2

up vote 0 down vote accepted

You can also go to Add-ons (Ctrl-Shift-A), Appearance section, and verify that the Default 4.0 theme exists and is the current one.

You may also follow the advice in Corrupt localstore.rdf of starting Firefox in Safe mode, select the option "Reset toolbars and controls" and click "Make Changes and Restart" :

image

It would be interesting to know if in Safe mode the icons are still broken. If not, then this is an add-on problem.

If this doesn't work, you may close Firefox, rename the file localstore.rdf, and let Firefox rebuild it. Be careful not to touch the Firefox installation folder.

share|improve this answer
    
Yes - Default 4.0 is the only theme present. –  Peter P Mar 23 '11 at 11:24
    
Added one more possibility above. –  harrymc Mar 23 '11 at 12:14
    
Great, thanks a lot - The "Safe Mode" option did the trick, the icons are fixed now. I did not know about Safe Mode, thanks for pointing it out :) –  Peter P Mar 23 '11 at 12:53

Go to View -> Toolbars, check "Tabs on Top" and uncheck "Menu Bar". This should bring the new UI style.

share|improve this answer
    
Thanks a lot, this fixes at least part of the problem :) Now, just the buttons still look ugly as hell, but it is far better now. –  Peter P Mar 23 '11 at 11:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.