Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The root user of Linux doesn't have permission to read/write a regular file, unless all users have permission to read/write this file, like below:

drwxrwsrwx ....... file_name

However the owner of the file can still read/write this file.

AND:

0) not the problem of execution, just read/write
1) not the problem of device because regular user can read/write it.
2) the result of command id:

uid=0(root) gid=0(root) groups=0(root)

so I don't think it's the problem of group.

So what other problems could be?

share|improve this question

migrated from stackoverflow.com Mar 23 '11 at 11:23

This question came from our site for professional and enthusiast programmers.

1  
You may get a better response asking your question in unix.stackexchange.com –  Johnsyweb Mar 23 '11 at 6:51
    
Is this filesystem on an NFS export? –  Kirby Todd Mar 23 '11 at 6:57
    
yes, I guess it maybe the problem of NFS. Thx a lot –  owen_water Mar 23 '11 at 7:38
    
If the output is really is drwxrwsrwx ....... file_nameand the seventh letter (s instead of - or x) isn't a typo, then the s means a SUID Bit is set -> S**(et) **U**(ser) **ID on execution. This means that other users can execute *file_name* with the same permissions as the user who owns *file_name*. But as root is above all users, it should be able to read the file. Guessing that you are on a GNU/Linux system: What message do you get when trying to read this file as root user? Also: Please describe how you do log in as root –  erch Dec 7 '13 at 20:08

2 Answers 2

chmod the files. I add issues with setting up scripts for my firewall on SlackWare 13.37, having the 'permission denied' error when trying to execute.

What I did was, for my problem, is as follows:

chmod 777 /bin/firewall-start

I don't know what exact number (777 in my case) to add after chmod command, but it's a start and I hope this helps.

share|improve this answer
3  
chmod 777 should never be the smart solution. –  Lorenzo Von Matterhorn Mar 24 '13 at 23:31
1  
The numbers are permission triplets (RWX) for user, group and other. Setting it to 777 means that the permission are set to readable, writeable and executable for everyone. Writable for everyone is very much not desired. Note that chmod also suppurts things like 'chmod u+x filename' to set executable for user. Much easier if you do not want to use numbers. –  Hennes Mar 24 '13 at 23:45

Check mounting options like 'rw' 'ro' (read, write issues), 'user' 'exec' (execution issues).

share|improve this answer
    
These options affect all users not only root. –  pabouk Nov 6 '13 at 14:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.