Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The proprietary ATI driver for Linux tends to misdetect dpi when I plug in different monitors (plugging into a TV over HDMI after using with a normal DVI monitor). Either it correctly detects it has a low dpi (and fonts are unreadably small) or it thinks it has a very high dpi (and fonts are absurdly large). How do I tell it to always use a specific dpi?

I have already set a DisplaySize in mm for "Configured Monitor" in /etc/X11/xorg.conf. It seems to lose track of this after a few mode changes with the amdcccle control panel.

share|improve this question

1 Answer 1

Use the MergedDPI option in your xorg.conf file.

Taken from the radeon(4) - Linux man page

Option "MergedDPI" "string"

The driver will attempt to figure out an appropriate DPI based on the DDC information and the orientation of the heads when in merged framebuffer mode. If this value does not suit you, you can manually set the DPI using this option.

For example, Option "MergedDPI" "100 100"

The default value is undefined.

share|improve this answer
    
That's for the radeon driver. I am using fglrx. –  joeforker Aug 20 '09 at 2:56
    
ah sorry, try # man fglrx | grep dpi; I can't find it online. –  Lee Aug 20 '09 at 10:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.