Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I navigate to System->Administration->Synaptic Package Manager it will prompt me for a password. The problem is that it always says I entered the wrong password.

If I run the command "gksudo synaptic" from the console, the password I enter works fine and Synaptic starts with no issues.

I'm guessing I configured something improperly when setting up the OS. Any ideas to get Synaptic to work from the Gnome panel?

I'm running Ubuntu 10.10.

share|improve this question
    
Are you an admin user? If not, are you entering the admin password or yours? –  Chance Mar 29 '11 at 18:16
    
@chance Yes, I am an administrator. –  juan2raid Mar 29 '11 at 18:23
    
Argh, this happens to me too! I end up always starting synaptic via sudo from a terminal when I want to use it. Funny thing: when gnome-settings-daemon isn't running, gksu and synaptic work correctly. –  Just Jake Mar 29 '11 at 20:41
add comment

2 Answers 2

up vote 2 down vote accepted
+50

On Ubuntu 10.04, the Synaptic menu entry calls gksu --description /usr/share/applications/synaptic.desktop /usr/sbin/synaptic Did you enable the root user? If you did, you either want to use the root password or change the menu to gksudo or add --sudo-mode to the current menu entry.

share|improve this answer
add comment

This might help :

  1. Ensure that gconf-editor is installed
  2. Press Alt-F2 and run gconf-editor
  3. Go to apps > gksu and tick the 'sudo-mode' box
  4. Try Synaptic again.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.