Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a simple network setup. A DSL connection from AT&T connected to a Belkin Play Wireless Router. Two computers are connected through ethernet and have no problems whatsoever.

Any device that connects wirelessly (laptops, desktops, iPhone, iPad, etc.) will connect without a problem (default WPA/WPA2 security settings). However, when browsing/etc (antyhing that uses internet access) it will often act like it is waiting for a response (for about 30-60 seconds) and then either suddenly start receiving or stop (saying it wasn't able to load the page).

As an example, on an iPhone using Safari, after clicking on a link it will act like it is loading but the progress bar does not fill. After the above period of time it will either 1) start loading the page 2) display the message "Safari could not load the website" and then immediately start loading the page or 3) display the previous message and not do anything else.

Signal strength doesn't seem to be an issue as this happens even with a full signal bar.

Have tried both networks (the regular 2.4Ghz and the 5GHz) and they both have the same problem.

Any suggestions as what this could be caused by? It's a difficult problem to describe so I have not found any possible reasons/solutions.

I've had similar issues in the past with different routers (a previous Linksys router would drop the wireless connection every few minutes) that were resolved by getting a different router. The fact that a different router has a similar yet different problem might suggest an interference problem but then it shouldn't be an issue on the different frequency (5GHz) unless there is a lot of interference.

share|improve this question

3 Answers 3

I had similar problem. Seting up a new SSID on router is worth trying.

My problem turned out to be cordless phone 1 metre above router. Placing 0.05mm copper foil from art suppliers between the two cured the problem.

A thick layer of aluminium foil would work just as well for a test.

share|improve this answer

As you have found, when a wireless router starts to show connection errors, replacing the router seems to be the quickest and surest fix. You could spend hours fiddling with things and investigating, but chances are good some capacitor on the wireless section of the router has failed, and it's just out of spec enough that it causes problems only when actively used.

With routers costing less and less every day, it's rarely worth the trouble. Replace it and be done with the problem.

However, if this is a consistent problem, you could be experiencing interference from other routers or radio devices in the area. I use NetStumbler to find all the networks, their channels, and signal power in order to choose which channels to operate on.

But since you've had problems in both bands I dismissed frequency problems. It's unlikely that you are running into the same kind of interference on both 2.4GHz and 5GHz bands.

Checking with NetStumbler or another wifi mapping tool will give you a lot of information, and if there are others using the same channels as you, you will be able to reconfigure your router to avoid or reduce the effect of shared frequencies.

Most new routers, however, already do this and choose clear channels, so it may not result in a better situation.

Lastly, if you have a regular A/B/G router, but not n, you might consider getting one. n routers use multiple frequencies and advanced RF techniques such as MIMO which may allow your devices to get through even terrible RF conditions in your area.

share|improve this answer
    
As the last 3 routers have all had problems, I'm not sure I would be done with it. –  Jordy Boom Mar 24 '11 at 15:07
    
@Jordy I've posted a bit more info that might lead you to a solution. Good luck! –  Adam Davis Mar 24 '11 at 17:52

I suspect the DNS server actually. Have you seen this post here? How do I diagnose not being able to reach a specific website as an end user?

http://www.grc.com/dns/benchmark.htm might be helpful in narrowing down the problem.

To very quickly test the DNS hypothesis, use http://code.google.com/speed/public-dns/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.