Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i can't mute when i plugged in a headphone on my laptop. But it works in Windows 7.

Here comes output from lshw command:

*-multimedia

         description: Audio device
         product: 82801I (ICH9 Family) HD Audio Controller
         vendor: Intel Corporation
         physical id: 1b
         bus info: pci@0000:00:1b.0
         version: 03
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress bus_master cap_list
         configuration: driver=HDA Intel latency=0
         resources: irq:47 memory:fc220000-fc223fff

I've tried to setup customized module to kernel module:

/etc/conf.d/modules:

module_snd_hda_intel_args="model=ich9"

But it just didn't work as expected.

Anyone could provide a nice solution here ? Thanks for any posts ;-P

share|improve this question

migrated from stackoverflow.com Mar 24 '11 at 2:12

This question came from our site for professional and enthusiast programmers.

    
This doesn't beling on Stack Overflow. Maybe move it to the Linux/Unix site? –  Peter Of The Corn Mar 24 '11 at 2:07
    
This isnt really a problem related to programming. This would be better suited on unix.stackexchange.com –  zobgib Mar 24 '11 at 2:08
    
How does alsamixer show your volume settings? More likely you're muting the wrong channel. –  new123456 Mar 24 '11 at 20:00
    
Card: HDA Intel and Chip: Conexant ID 5051 –  warl0ck Mar 25 '11 at 7:15

1 Answer 1

up vote 1 down vote accepted

You don't have the same chip as me, but this worked for me:

options snd-hda-intel model=lenovo-101e 
options snd-hda-intel position_fix=1 enable=yes

Of course, as you might guess, I have a Lenovo laptop. This might not work for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.