Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two monitors. The master one (17") is 1yo, and the secondary (15") is really old, like 4yo.
This old screen is having problems displaying colors... They are a little bit darker, what is a problem when I'm viewing pics.

I have a GeForce 9800, so I changed some settings inside nvidia-settings, that fit better with this second screen.
But those settings just are applied when I first open nvidia-settings. First time I configured this, it worked. I turned off computer, next day turned it on, and screen is dark again. As soon as I open nvidia-settings again, the screens get lighter again!

How can I make those settings permanent and loaded at startup?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

It looks like you can run nvidia-settings on the command line, like so:

nvidia-settings --config=~/.nvidia-settings --load-config-only

Try and get this working on the command line. Once it is ready, you can just add this to run at boot. Check the answers juanjux and I gave to this question on how to add a script to run at boot.

Note, this will enable the script to run at boot, and not just when the GDM/KDE graphical environment starts up.

share|improve this answer
    
I think your answer do exactly what I need. But somehow when I run this command it throws me thousands of errors, all about 'anything could be assigned (no display connection)'. But if I simply open the program, it works ='( –  Igoru Aug 21 '09 at 1:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.