Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Lots of websites don't seem to be loading at all, in ALL of my browsers (Safari, Chrome, FF). Others don't load any of the images. I'm using Mac OS X 10.6

The websites work fine-- if I restart in Windows, everything works. What could cause this? How can I fix it?

edit: I should specify that many other websites--like google and superuser--appear to work just fine.

share|improve this question

2 Answers 2

Could be an outdated DNS cache. Its fairly simple to troubleshoot - check if you can reach the sites with an external proxy (i tend to use daveproxy). If that fixes it, try flushing your DNS cache, and if that dosen't fix it, try swapping your DNS server.

share|improve this answer
    
I think this is the problem, but I'm still having trouble. Tried flushing the DNS cache first, no change. Tried changing the DNS servers (to Google's public DNS), no change. Restarted, and now a few more pages are working that weren't before. But still, a few aren't working. –  Jeff Mar 24 '11 at 6:21
up vote 0 down vote accepted

The problem had to do with PeerGuardian-type services; in particular, it wasn't allowing traffic even after the program was closed. Re-opening the program and whitelisting everything worked. @Journeyman's advice is a good troubleshooting tip if you're having the same problem, though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.