Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm installing Office 2007 (or any of the individual Office 2007 products) on a clean Vista SP2 machine and installer is failing with error 2203: "An internal error has occurred. c:\windows\installer\4dd58d1.msi -2147287035)..." (Note that the 4dd58d1.msi filename is just an example here - it may be different on different instances of the install process.)

Googling for error 2203 gives results relating to read-only/permission problems with the msi source files but I've verified this is not the case.

Have tried multiple Office 2007 install sources and same result.

Thoughts?

share|improve this question
    
Tried running the installers as administrator? –  John T Aug 20 '09 at 4:40
    
Which version of vista? –  Troggy Aug 20 '09 at 4:40
    
@John T - I have. Both native as admin and with runas. @Troggy - Vista Ultimate SP2. –  Matt Aug 21 '09 at 0:47

6 Answers 6

In Windows 7:

  1. Run %TEMP% then temporary folder will open.

  2. Go up one level and right click on TEMP folder

  3. Take Ownership of the folder.

  4. Now Windows 7 will allow to install Office 2007 and other 3rd party software too.

share|improve this answer

Have you tried turning off UAC? This has caused a number of installing issues for me previously.

EDIT: Where are you running your install from (CD/Local Drive/Network Drive)? Do you have full access to this location?

share|improve this answer
    
hi Craig I did indeed. I actually turned off UAC immediately upon building the machine. –  Matt Aug 20 '09 at 4:53
    
This may sound odd but try turning UAC on again. There have been a few issues with software failing to install if UAC is turned off. This really shouldn't affect Office but it can't hurt to try –  Pär Björklund Aug 20 '09 at 7:19

Quoting from this article :

I recently had this problem installing third party software.
Some software uses the c:\documents and settings\%username%\local settings\temp folder to store files temporarily during install.
I checked the permissions on this, set them to 'full' for my account and system, and everything went ok.

share|improve this answer

It's a permissions error on one of the windows folders. I tried permissions changes to %temp% and /Windows/Installers but the problem only went away when I did a Windows Refresh on my (new) Windows 8 gigabyte laptop.

share|improve this answer

Try to start installation under administrator account.

share|improve this answer

Do you have an antivirus product installed? Some have the option to block installations from the Temp directory. The MSIs will expand there first before install.

share|improve this answer
    
Hi Mark - I do (AVG Free). I tried with antivirus on then off. Ultimately I was successful however there was no rhyme or reason to it that I could tell. –  Matt Oct 16 '09 at 5:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.